Bug 1713925

Summary: dnf upgrade fails: nothing provides zabbix = 4.0.7-2.fc30
Product: [Fedora] Fedora Reporter: Michael Hampton <error>
Component: zabbixAssignee: Volker Fröhlich <volker27>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: high    
Version: 30CC: bennie.joubert, dan, gwync, mstevens, nberrehouc, orion, volker27, waclaw66
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: zabbix-4.0.7-3.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-01 00:52:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Michael Hampton 2019-05-25 20:00:19 UTC
Description of problem:
It is not possible to upgrade Zabbix agent or server from 4.0.5-1 to 4.0.7-2.


Version-Release number of selected component (if applicable):
 zabbix                   x86_64      1:4.0.7-2.fc30         updates      328 k
 zabbix-agent             x86_64      1:4.0.7-2.fc30         updates      202 k
 zabbix-server            noarch      1:4.0.7-2.fc30         updates       20 k
 zabbix-server-mysql      x86_64      1:4.0.7-2.fc30         updates      730 k
 zabbix-web               noarch      1:4.0.7-2.fc30         updates      4.0 M
 zabbix-web-mysql         noarch      1:4.0.7-2.fc30         updates      8.5 k


How reproducible:
Always


Steps to Reproduce:
1. dnf upgrade
2. dnf --best --allowerasing upgrade


Actual results:
# dnf upgrade       
Last metadata expiration check: 0:01:03 ago on Sat 25 May 2019 07:48:49 PM UTC.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package zabbix-agent-4.0.5-1.fc30.x86_64
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-agent-1:4.0.7-2.fc30.x86_64
 Problem 2: cannot install the best update candidate for package zabbix-server-4.0.5-1.fc30.noarch
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-server-1:4.0.7-2.fc30.noarch
 Problem 3: cannot install the best update candidate for package zabbix-server-mysql-4.0.5-1.fc30.x86_64
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-server-mysql-1:4.0.7-2.fc30.x86_64
  - nothing provides zabbix-server = 4.0.7-2.fc30 needed by zabbix-server-mysql-1:4.0.7-2.fc30.x86_64
 Problem 4: cannot install the best update candidate for package zabbix-web-4.0.5-1.fc30.noarch
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-web-1:4.0.7-2.fc30.noarch
 Problem 5: cannot install the best update candidate for package zabbix-web-mysql-4.0.5-1.fc30.noarch
  - nothing provides zabbix-web = 4.0.7-2.fc30 needed by zabbix-web-mysql-1:4.0.7-2.fc30.noarch
 Problem 6: problem with installed package zabbix-web-4.0.5-1.fc30.noarch
  - package zabbix-web-4.0.5-1.fc30.noarch requires zabbix = 4.0.5-1.fc30, but none of the providers can be installed
  - cannot install both zabbix-1:4.0.7-2.fc30.x86_64 and zabbix-4.0.5-1.fc30.x86_64
  - cannot install both zabbix-4.0.5-1.fc30.x86_64 and zabbix-1:4.0.7-2.fc30.x86_64
  - cannot install the best update candidate for package zabbix-4.0.5-1.fc30.x86_64
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-web-1:4.0.7-2.fc30.noarch
================================================================================
 Package                  Arch        Version                Repository    Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 zabbix                   x86_64      1:4.0.7-2.fc30         updates      328 k
Skipping packages with broken dependencies:
 zabbix-agent             x86_64      1:4.0.7-2.fc30         updates      202 k
 zabbix-server            noarch      1:4.0.7-2.fc30         updates       20 k
 zabbix-server-mysql      x86_64      1:4.0.7-2.fc30         updates      730 k
 zabbix-web               noarch      1:4.0.7-2.fc30         updates      4.0 M
 zabbix-web-mysql         noarch      1:4.0.7-2.fc30         updates      8.5 k

Transaction Summary
================================================================================
Skip  6 Packages

Nothing to do.
Complete!

# dnf --best --allowerasing upgrade       
Last metadata expiration check: 0:01:30 ago on Sat 25 May 2019 07:48:49 PM UTC.
Error: 
 Problem 1: problem with installed package zabbix-web-mysql-4.0.5-1.fc30.noarch
  - cannot install the best update candidate for package zabbix-web-mysql-4.0.5-1.fc30.noarch
  - nothing provides zabbix-web = 4.0.7-2.fc30 needed by zabbix-web-mysql-1:4.0.7-2.fc30.noarch
 Problem 2: problem with installed package zabbix-web-4.0.5-1.fc30.noarch
  - cannot install the best update candidate for package zabbix-web-4.0.5-1.fc30.noarch
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-web-1:4.0.7-2.fc30.noarch
 Problem 3: problem with installed package zabbix-server-mysql-4.0.5-1.fc30.x86_64
  - cannot install the best update candidate for package zabbix-server-mysql-4.0.5-1.fc30.x86_64
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-server-mysql-1:4.0.7-2.fc30.x86_64
  - nothing provides zabbix-server = 4.0.7-2.fc30 needed by zabbix-server-mysql-1:4.0.7-2.fc30.x86_64
 Problem 4: problem with installed package zabbix-server-4.0.5-1.fc30.noarch
  - cannot install the best update candidate for package zabbix-server-4.0.5-1.fc30.noarch
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-server-1:4.0.7-2.fc30.noarch
 Problem 5: problem with installed package zabbix-agent-4.0.5-1.fc30.x86_64
  - cannot install the best update candidate for package zabbix-agent-4.0.5-1.fc30.x86_64
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-agent-1:4.0.7-2.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)
root@hozen ~ 
# dnf --best --allowerasing upgrade             
Last metadata expiration check: 0:00:06 ago on Sat 25 May 2019 07:51:09 PM UTC.
Error: 
 Problem 1: problem with installed package zabbix-web-mysql-4.0.5-1.fc30.noarch
  - cannot install the best update candidate for package zabbix-web-mysql-4.0.5-1.fc30.noarch
  - nothing provides zabbix-web = 4.0.7-2.fc30 needed by zabbix-web-mysql-1:4.0.7-2.fc30.noarch
 Problem 2: problem with installed package zabbix-web-4.0.5-1.fc30.noarch
  - cannot install the best update candidate for package zabbix-web-4.0.5-1.fc30.noarch
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-web-1:4.0.7-2.fc30.noarch
 Problem 3: problem with installed package zabbix-server-mysql-4.0.5-1.fc30.x86_64
  - cannot install the best update candidate for package zabbix-server-mysql-4.0.5-1.fc30.x86_64
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-server-mysql-1:4.0.7-2.fc30.x86_64
  - nothing provides zabbix-server = 4.0.7-2.fc30 needed by zabbix-server-mysql-1:4.0.7-2.fc30.x86_64
 Problem 4: problem with installed package zabbix-server-4.0.5-1.fc30.noarch
  - cannot install the best update candidate for package zabbix-server-4.0.5-1.fc30.noarch
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-server-1:4.0.7-2.fc30.noarch
 Problem 5: problem with installed package zabbix-agent-4.0.5-1.fc30.x86_64
  - cannot install the best update candidate for package zabbix-agent-4.0.5-1.fc30.x86_64
  - nothing provides zabbix = 4.0.7-2.fc30 needed by zabbix-agent-1:4.0.7-2.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)


Expected results:
dnf upgrade completes successfully


Additional info:
Digging into the spec file, it appears that the new packages now have an Epoch: 1, but the Requires: zabbix-whatever lines weren't also updated to have the new Epoch.

Comment 1 Nicolas Berrehouc 2019-05-26 16:08:29 UTC
Same issues with Server and Clients.

Comment 2 Morten Stevens 2019-05-29 13:57:51 UTC
I'm able to reproduce this on a clean F30 machine. All zabbix subpackages are broken in F30 + rawhide.

Latest commit:

https://src.fedoraproject.org/rpms/zabbix/c/0c79509c840168536b559738f7e29cf91b66b35b?branch=master

That's why subpackages like zabbix-agent probably will not work anymore, because they require %{name} = %{version}-%{release} but we need something like %{name} = %{epoch}:%{version}-%{release}

Comment 3 Fedora Update System 2019-05-30 20:08:49 UTC
FEDORA-2019-29814eadd0 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-29814eadd0

Comment 4 Fedora Update System 2019-05-31 00:53:20 UTC
zabbix-4.0.7-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-29814eadd0

Comment 5 Nicolas Berrehouc 2019-05-31 14:32:32 UTC
The Zabbix packages update is now possible.

Comment 6 Fedora Update System 2019-06-01 00:52:19 UTC
zabbix-4.0.7-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.