Bug 1713986

Summary: Can't Resize display in virtualbox guest
Product: [Fedora] Fedora Reporter: Knud Christiansen <knud.skrald>
Component: virtualbox-guest-additionsAssignee: Hans de Goede <hdegoede>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: hdegoede, michael.thayer, sergio
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: virtualbox-guest-additions-6.0.10-1.fc30 virtualbox-guest-additions-6.0.10-1.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-07-23 01:07:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Knud Christiansen 2019-05-26 11:43:34 UTC
Description of problem:

Changing resolution in the guest (KDE spin F31 kernel 5.1.0-1 f31.x86_64 or f31 kernel 5.2.0-0.rc0.git.1)

You a short flickering and the resolution stays the same, mouse position (actual compared to visible) is corrupted.
Can partly be restored by shifting to fullscreen console in the guest by HOST+F2 =>HOST+F1

I have tried Guest desktops both Gnome, Cinnamon, either do the same or give an error.

It are complete fresh guest F31 installs

HOST is F30 ...but I dont believe it matters because problem was also with older F28 HOST

Using VboxSVGA, have tried the 2 other vbox display adapters VMSVGAm VboxVGA, does not affect the problem.



Version-Release number of selected component (if applicable):
VirtualBox-guest-additions 6.0.8   (Host is also Vbox 6.0.8)

How reproducible:
Always

Just make fresh F31 install as a guest

I am making a new bug as I can not reopen
https://bugzilla.redhat.com/show_bug.cgi?id=1708506#c14

Knud

Comment 1 Michael Thayer 2019-05-26 12:13:09 UTC
VirtualBox developer here.  I have seen something similar in upstream VirtualBox and tracked what I saw down in the code.  Please open a bug ticket in the VirtualBox bugtracker[1], add the link to this ticket and I can provide you with a test build which may fix it.  (As soon as I get round to committing the fix to the code.)

[1] https://www.virtualbox.org/wiki/Bugtracker

Comment 2 Knud Christiansen 2019-05-26 20:29:17 UTC
BUG created in VirtualBox bugtracker https://www.virtualbox.org/ticket/18677

Comment 3 Fedora Update System 2019-07-18 22:13:49 UTC
FEDORA-2019-57faf7c6ea has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-57faf7c6ea

Comment 4 Fedora Update System 2019-07-18 22:16:28 UTC
FEDORA-2019-195a62c317 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-195a62c317

Comment 5 Fedora Update System 2019-07-19 01:34:45 UTC
virtualbox-guest-additions-6.0.10-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-57faf7c6ea

Comment 6 Fedora Update System 2019-07-19 03:25:57 UTC
virtualbox-guest-additions-6.0.10-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-195a62c317

Comment 7 Fedora Update System 2019-07-23 01:07:49 UTC
virtualbox-guest-additions-6.0.10-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2019-07-29 01:44:51 UTC
virtualbox-guest-additions-6.0.10-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.