Bug 1715434

Summary: Slow Mouse Pointer Speed - Logitech MX Master 2s - Bluetooth connection
Product: [Fedora] Fedora Reporter: fhortner
Component: bluezAssignee: Don Zickus <dzickus>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 30CC: bnocera, btissoir, dennis, dwmw2, dzickus, extras-orphan, jdisnard, jkeating, kellin, kevin, mboddu, pbrobinson, peter.hutterer, spacewar, thrcka, xgl-maint, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-07 18:50:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description fhortner 2019-05-30 11:01:13 UTC
Description of problem:
I upgraded from Fedora 29 to Fedora 30.
On Fedora 29 the mouse worked flawlessly
After the Upgrade the mouse (Logitech MX Master 2s) pointer speed is extremely slow, usable, but almost to work productivly.
The mouse is connected via Bluetooth.
I tried the same mouse on another Fedora 30 machine with exactly the same issue, the pointer speed got very slow after upgrade from Fedora 29.
Increasing the speed via settings did not help but only increases the pointer speed of all other mice.

So for test purpose I connected a Logitech Triathlon, also via Bluetooth.
This mouse works without any issue with normal pointer speed.

I also tried it under gnome wayland. The problem remains.

Connecting the mouse via the unifying dongle the mouse works as expected.

Version-Release number of selected component (if applicable):
Fedora 30

How reproducible:
Tested on 2 different Fedora 30 machines

Steps to Reproduce:
1. connect Logitech MX Master 2s via Bluetooth in KDE

Actual results:
slow mouse pointer speed
Increasing pointer speed via KDE settings is no solution, because then the pointer speed of other mice increases drasticly.
impossible to work productivly

Expected results:
normal mouse pointer speed as it was in Fedora 29 or any other OS

Additional info:
Tested the exactly same mouse on three differnet Fedora machines. Two Fedora 30, one with Fedora 29.
Mouse works as expected on Fedora 29.
Mouse is too slow on both Fedora 30 machines.

Comment 1 Peter Robinson 2019-07-03 07:18:59 UTC
Please don't move it to the wrong component.

Please also report useful information like what kernel you're running plus what version of bluez.

Comment 2 fhortner 2019-07-07 08:10:27 UTC
Sorry for the late replay,

here the additional information:
bluez version: 5.50 via bluetoothctl --version
Kernel version: 5.1.15-300.fc30.x86_64

about moving to the wrong component:
it was very difficult to find the correct component, because I do not exactly know what is responsible for exactly what.
For example: on Fedora 29 I also have bluez 5.50, so the same version as on Fedora 30,
but on Fedora 29 I do not have any issue with the cursor speed of the Logitech MX Master 2s

Comment 3 fhortner 2019-07-07 08:24:26 UTC
Upgraded Kernel to 5.1.16-300.fc30.x86_64

same issue

Comment 4 fhortner 2019-08-03 09:58:20 UTC
Hi all,

the problem with the slow mouse pointer persists.
The lates updates are installed, but it still persists.

current kernel is 5.1.20-300.fc30.x86_64

The strange thing is, that another bluetooth mouse (Logitech Triathlon M270) works flewlessly on the same machine with exactly the same configuration.

May it be, that something like DPI settings for the Logitech MX Master 2S is wrong configured?

Am I really the only one having this issue?

Thanks for your help!

Comment 5 Zbigniew Jędrzejewski-Szmek 2019-08-03 10:25:30 UTC
Pfff, bluetooth vs unifying receiver.

@fhortner: please specify systemd-udev version.

Comment 6 fhortner 2019-08-03 11:30:50 UTC
/lib/systemd/systemd-udevd --version on the Fedora 30 machine shows

in Fedora 29 it just shows 239

Comment 7 fhortner 2019-08-04 07:35:05 UTC
Maybe some additional information:

I am using a HP 250 G2 and a Elitebook 840 G3

HP 250 G4 i3 5005 @2.0GHz with a Realtek RT8723BE wireless card

the second machine is a:
HP Elitebook 840 G3 core i5 6200 @2.3GHz with a Intel Corporation Dual Band Wireless-AC 8260 wireless card

Comment 8 Peter Hutterer 2019-08-07 04:06:29 UTC
systemd has a hwdb entry for this mouse, the relevant bits are:

# Logitech MX Master 2S (via Logitech Unifying Receiver)
mouse:usb:v046dp4069:name:Logitech MX Master 2s:

# Logitech MX Master 2S (via Bluetooth)
mouse:bluetooth:v046dpb019:name:MX Master 2S Mouse:

So I suspect the second entry is wrong (come to think of it, 2000hz over bluetooth doesn't sound right anyway). Run the mouse-dpi-tool from libevdev-utils and adjust the entry accordingly, if that works it's best to submit an upstream PR for systemd. The original PR where this got merged is here: https://github.com/systemd/systemd/pull/11078. Best to leave a note and ask why the discrepancy.

I suspect that if your DPI isn't 1000, then either you or Emil (upstream) have configured the mouse before and the profile isn't as-factory anymore.

Comment 9 fhortner 2019-08-07 18:48:35 UTC
Hi Peter,

thanks for the hint, I tried it with a custom hwdp for the MX Master 2S and set it to MOUSE_DPI=1000@2000
and updated systemd-hwdb

this did the trick, seems to work.
So I will try to submit it.