Bug 171633

Summary: [LSI 4.8 feat] ipv6 support needs to be added to userpace tools
Product: Red Hat Enterprise Linux 4 Reporter: Mike Christie <mchristi>
Component: iscsi-initiator-utilsAssignee: Mike Christie <mchristi>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4.7CC: andriusb, berthiaume_wayne, borgan, cnitin, coughlan, josh.weiser, khtan, riek, smitha.narayan, vamskris
Target Milestone: ---Keywords: FutureFeature, OtherQA
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-08-26 12:40:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 445361, 458123    

Description Mike Christie 2005-10-24 16:06:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Currently iscsi tools and the driver only support ipv4. Cisco is releasing ipv6 support in its targets and would like the iscsi tools and driver to support it. This bugzilla is for the addition of ipv6 support to the userspce iscsi tools. The driver bugzilla is here https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167555

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run tools
2. no ipv6 support
3.
  

Additional info:

Comment 6 Vamsi Krishna Sadhu 2006-09-11 06:05:39 UTC
I have given some more support for the IPV6 at user space and kernel space 
level,that will inturn contains sending ipv6 info to the kernel and there it 
will distinguish between IPV4/6 and then get connect.

In case if you need the patch, i will send that across to you.
 


Comment 8 RHEL Product and Program Management 2007-03-10 01:12:40 UTC
This bugzilla had previously been approved for engineering
consideration but Red Hat Product Management is currently reevaluating
this issue for inclusion in RHEL4.6.

Comment 11 Andrius Benokraitis 2007-08-23 17:31:11 UTC
This has been deferred to RHEL 4.7 due to resource constraints and the stated
medium severity.

Comment 13 Andrius Benokraitis 2008-05-06 14:13:49 UTC
This has been deferred to RHEL 4.8 due to just receiving hardware and firmware
to test this.

Comment 15 RHEL Product and Program Management 2008-08-26 12:40:12 UTC
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.