Bug 1717966

Summary: [Fedora IOT] Unable to install pcp on Fedora IoT
Product: [Fedora] Fedora Reporter: Christopher Wawak <cwawak>
Component: pcpAssignee: Nathan Scott <nathans>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: brolley, dustymabe, fche, jonathan, lberk, mgoodwin, miabbott, nathans, philwyett, rfairley, scox, walters
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-19 03:41:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1352154    

Description Christopher Wawak 2019-06-06 14:36:20 UTC
Description of problem:
When I run rpm-ostree install cockpit-pop, it fails.

Version-Release number of selected component (if applicable):
Fedora-IoT-ostree-x86_64-30-20190515.1.iso
rpm-ostree-2019.3-1.fc30.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora IoT box
2. Try to install cockpit-pop
3. Fails

Actual results:
[root@hassio cwawak]# rpm-ostree install cockpit-pcp
Checking out tree f7e0bc6... done
Enabled rpm-md repositories: updates-modular fedora fedora-modular updates
rpm-md repo 'updates-modular' (cached); generated: 2019-06-06T02:04:21Z
rpm-md repo 'fedora' (cached); generated: 2019-04-25T23:49:41Z
rpm-md repo 'fedora-modular' (cached); generated: 2019-04-25T23:47:30Z
rpm-md repo 'updates' (cached); generated: 2019-06-06T00:42:08Z
Importing rpm-md... done
Resolving dependencies... done
Will download: 6 packages (1.8 MB)
Downloading from 'updates-modular'... done
Downloading from 'updates'... done
Importing packages... done
Checking out packages... done
Running pre scripts... done
Running post scripts... done
error: Running %post for pcp: Executing bwrap(/bin/sh): Child process killed by signal 1; run `journalctl -t 'rpm-ostree(pcp.post)'` for more information
[root@hassio cwawak]# journalctl -t 'rpm-ostree(pcp.post)'
-- Reboot --
Jun 06 10:28:48 hassio.x.wawak.org rpm-ostree(pcp.post)[1904]: touch: cannot touch '/var/lib/pcp/pmns/.NeedRebuild': No such file or directory
Jun 06 10:28:48 hassio.x.wawak.org rpm-ostree(pcp.post)[1904]: chmod: cannot access '/var/lib/pcp/pmns/.NeedRebuild': No such file or directory
Jun 06 10:28:48 hassio.x.wawak.org rpm-ostree(pcp.post)[1904]: /usr/pcp.post: line 52: cd: /var/lib/pcp/pmns: No such file or directory
Jun 06 10:28:48 hassio.x.wawak.org rpm-ostree(pcp.post)[1904]: /usr/pcp.post: line 53: cd: HOME not set

Expected results:
Installed package.

Additional info:

Comment 1 Christopher Wawak 2019-06-17 20:41:29 UTC
oops, probably not rpm-ostree at fault here.

Comment 2 Christopher Wawak 2019-06-17 20:41:43 UTC
oops, probably not rpm-ostree at fault here.

Comment 3 Colin Walters 2019-06-17 20:54:37 UTC
> oops, probably not rpm-ostree at fault here.


Achieving transactional/offline updates does require some changes in some cases to how software is managed.  Only looking at this briefly I think PCP needs to move basically everything it's doing in %post to be part of the systemd unit.

Comment 4 Nathan Scott 2019-08-19 03:41:32 UTC

*** This bug has been marked as a duplicate of bug 1702226 ***