Bug 1721158

Summary: Please update Barman tot follow the upstream package split
Product: [Fedora] Fedora Reporter: Marco Nenciarini <marco.nenciarini>
Component: barmanAssignee: Francisco Javier Tsao Santín <tsao>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dbmacartney, tsao
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: barman-2.8-3.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-07-20 02:33:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marco Nenciarini 2019-06-17 13:38:57 UTC
Description of problem:

Current Barman packaging do not follow the upstream's packaging recommendations.

Version-Release number of selected component (if applicable):

2.8

Additional information:

In Barman 2.8, the code of barman-cli has been merged in the barman main code, so the source should now produces three packages: barman, barman-cli and the common library (python?-barman)

You can see the current spec by looking at PGDG yum GIT at https://git.postgresql.org/gitweb/?p=pgrpms.git;a=tree;f=rpm/redhat/master/barman/master or at the upstream's source package for RHEL7 at https://dl.2ndquadrant.com/default/release/browse/rpm/src_packages/centos/7/x86_64/11/barman-2.8-2.el7.src.rpm

Comment 1 Francisco Javier Tsao Santín 2019-06-19 00:17:13 UTC
(In reply to Marco Nenciarini from comment #0)
> 
> In Barman 2.8, the code of barman-cli has been merged in the barman main
> code, so the source should now produces three packages: barman, barman-cli
> and the common library (python?-barman)
> 
> You can see the current spec by looking at PGDG yum GIT at
> https://git.postgresql.org/gitweb/?p=pgrpms.git;a=tree;f=rpm/redhat/master/
> barman/master or at the upstream's source package for RHEL7 at
> https://dl.2ndquadrant.com/default/release/browse/rpm/src_packages/centos/7/
> x86_64/11/barman-2.8-2.el7.src.rpm

Hello Marco,

Thanks for commenting it. I updated the spec file, and I built the packages in Rawhide.

Please take a look if you can, and if you see it ok, I'll make the changes at f30 branch.

Best regards.

Comment 2 Marco Nenciarini 2019-06-26 15:28:53 UTC
I looked at the package and it seems to be ok.

I've briefly tried it in a Rawhide Docker container and everything worked as expected.

The only issue i found is in the barman config file:

[root@7d352f4d8e1f barman-packaging]# grep '\.d' /etc/barman/barman.conf
; For example place the 'main' server section in /etc/barman/conf.dmain.conf
configuration_files_directory = /etc/barman.d

As you can see, the first miss a / and the second has not been modified.

I suggest to change the following line in the spec:

sed -i 's|/etc/barman.d/|/etc/barman/conf.d|g' %{buildroot}%{_sysconfdir}/barman/barman.conf

to:

sed -i 's|/etc/barman.d|/etc/barman/conf.d|g' %{buildroot}%{_sysconfdir}/barman/barman.conf

Thaks for your support.

Regards,
Marco

Comment 3 Fedora Update System 2019-06-26 22:17:56 UTC
FEDORA-2019-5f825508e1 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5f825508e1

Comment 4 Francisco Javier Tsao Santín 2019-06-26 22:26:26 UTC
Thanks again for your comments, Marco. I fixed the sed parameter, and I updated the rawhide package again. Also I submitted an update for F30 as you can see.

Best regards.

Comment 5 Fedora Update System 2019-06-27 01:41:47 UTC
barman-2.8-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5f825508e1

Comment 6 Fedora Update System 2019-07-20 02:33:06 UTC
barman-2.8-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.