Bug 1723568

Summary: After kernel upgrade to Linux amd2 5.1.12-300.fc30.x86_64 #1 VirtualBox guest freezes
Product: [Fedora] Fedora Reporter: vjragx <vjragx>
Component: virtualbox-guest-additionsAssignee: Hans de Goede <hdegoede>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 30CC: hdegoede, michael.thayer, sergio
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Windows   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-25 17:03:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description vjragx 2019-06-24 20:19:28 UTC
Description of problem:

After kernel upgrade to Linux amd2 5.1.12-300.fc30.x86_64 #1 VirtualBox guest freezes

Version-Release number of selected component (if applicable):
Fedora 30 X86_64

How reproducible:
install latest kernel via dnf update 5.1.12-300.fc30.x86_64 and try to run Oracle Virtual box 5.2.30 or 6.0.8 the guest OS freezes and Fedora has to be force shutdown and watchdog stalls and machine has to be forcefully powercycled manually

Steps to Reproduce:
1.Install latest kernel 5.1.12-300 via dnf update

2.Boot the VirtualBox VM running a Windows host (i have Windows 7) 

3.The guest OS will freeze in 3 to 4 minutes  and machine has to be forcefully power cycled and host OS (fedora 30) is unable to kill the VM and it becomes zombie and unable to complete the shutdown process. Host OS stalls at watchdog

Actual results:


Expected results:


Additional info:
WORKAROUND:: I found out that by uninstalling the VirtualBox Guest additions on the guest as soon as the guest boots the guest becomes stable but display resolution is lost, I only get a 800x600 resolution

PS:I will try rolling back to older kernel( I'm a novice in Linux kindly bear with me if any of my reporting is incorrect)

Thank you
VJ

Comment 1 vjragx 2019-06-24 21:16:51 UTC
Hello team,

As mentioned earlier, I downgraded using the dnf downgrade kernel command and now I have kernel 5.0.9-301.fc30.x86_64 #1, and installed the kernel-devel kernel-devel-5.0.9-301.fc30.x86_64 and ran the command sudo /sbin/vboxconfig after which I had to  reboot the host once.

After this the host is successfully able to start the virtual Box (5.2.30 r130521 (Qt5.6.1)) and then I again installed the virtual box guest addition for 5.2.30.

now everything looks stable even after 10 mins most apps on the guest seems to be working and there's no freeze on the guest as of now.

hope this info is useful.

thank you
VJ

Comment 2 vjragx 2019-06-24 21:42:24 UTC
Hello team,

I'm sorry, I guess I was too quick to jump the gun. The problem persists even on the downgraded kernel.

thank you
VJ

Comment 3 Sergio Basto 2019-06-24 21:46:23 UTC
if you want use virtualbox-guest-additions package provide by Fedora you shouldn't download iso and run vboxconfig , all should work out of the box 

for example: https://bugzilla.redhat.com/show_bug.cgi?id=1695377#c7

Comment 4 vjragx 2019-06-24 21:48:58 UTC
ata2.00: status: { DRDY }

ata2.00: cmd 60/00:e8:f8:d5:a3/01:00:02:00:00/40 tag 29 ncq dma 131072 in
         res 40/00:e8:f8:d5:a3/00:00:02:00:00/40 Emask 0x10 (ATA bus error)

ata2.00: failed command: READ FPDMA QUEUED

ata2.00: irq_stat 0x00400000, PHY RDY changed

ata2.00: exception Emask 0x10 SAct 0x20000000 SErr 0x90202 action 0xe frozen

GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed

gkr-pam: unable to locate daemon control file

radeon 0000:01:00.0: failed VCE resume (-110).

ACPI Error: Evaluating _BCM failed (20181213/video-364)

ACPI Error: Method parse/execution failed \_SB.PCI0.PB21.VGA.LCD._BCM, AE_NOT_FOUND (20181213/psparse-529)
ACPI BIOS Error (bug): Could not resolve [\_SB.PCI0.PB21.VGA.LCD._BCM.AFN7], AE_NOT_FOUND (20181213/psargs-330)

Comment 5 vjragx 2019-06-24 21:52:57 UTC
(In reply to Sergio Monteiro Basto from comment #3)
> if you want use virtualbox-guest-additions package provide by Fedora you
> shouldn't download iso and run vboxconfig , all should work out of the box 
> 
> for example: https://bugzilla.redhat.com/show_bug.cgi?id=1695377#c7

thanks for the reply,

I'll try that.

Comment 6 vjragx 2019-06-25 17:03:43 UTC
thank you very much for the help.