Bug 1724169

Summary: Missing MPLv2.0 in License
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: perl-IO-Socket-SSLAssignee: Paul Howarth <paul>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: caillon+fedoraproject, jose.p.oliveira.oss, paul, perl-devel, rhughes, rstrode, sandmann
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: perl-IO-Socket-SSL-2.066-5.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1724434 (view as bug list) Environment:
Last Closed: 2019-06-26 15:16:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Petr Pisar 2019-06-26 11:49:23 UTC
I noticed IO-Socket-SSL-2.066 sources distribute Public Suffix list from <https://publicsuffix.org/list/> in lib/IO/Socket/SSL/PublicSuffix.pm file. The data carry it's own license declaration:

// This Source Code Form is subject to the terms of the Mozilla Public
// License, v. 2.0. If a copy of the MPL was not distributed with this
// file, You can obtain one at https://mozilla.org/MPL/2.0/.

I believe perl-IO-Socket-SSL should add MPLv2.0 to the License tag.

Comment 2 Petr Pisar 2019-06-27 05:28:41 UTC
> -# openssl for Test-client-performs-Post-Handshake-Authentication.patch
> -BuildRequires: openssl

This was there because of /usr/bin/openssl tool. I can see you already have had "openssl >= 0.9.8". Should that be openssl-libs?

Comment 3 Paul Howarth 2019-06-27 11:55:03 UTC
(In reply to Petr Pisar from comment #2)
> > -# openssl for Test-client-performs-Post-Handshake-Authentication.patch
> > -BuildRequires: openssl
> 
> This was there because of /usr/bin/openssl tool. I can see you already have
> had "openssl >= 0.9.8". Should that be openssl-libs?

Yes, it should. That dependency dates back to before the openssl/openssl-libs split in Fedora 18.