Bug 172422

Summary: main: action, subsystem or devpath missing
Product: [Fedora] Fedora Reporter: Pete Zaitcev <zaitcev>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-01-24 10:40:50 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pete Zaitcev 2005-11-04 03:11:28 EST
Description of problem:

The following messages appear in /var/log/messages when an input device
is connected or disconnected:

Nov  3 23:43:35 lembas udev[2626]: main: action, subsystem or devpath missing

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run tail -f /var/log/messages
2. Plug in a USB keyboard
3. Unplug the keyboard
Actual results:

Extra messages

Expected results:

Sensible messages only

Additional info:

See also bug 169387 for RHEL 4 and bug 169103 for FC4.

The root cause is that drivers/input/input.c calls call_usermodehelper()
directly, instead of going through kobject_hotplug().

This should be fixed in kernel, but I am not quite sure how.
We are going to debate this with Greg and Vojtech, I suspect.

Harald, please do not reassign this bug to kernel component.
This bug is a request to plug the message specifically, because
if we hash out a solution to provide a valid devpath, this would
require additional testing to make sure that udev reacts right.
Sounds not really like a bug, more like upstream rebasing.

If you want wontfix this, it's fine.
Comment 1 Kay Sievers 2005-11-10 20:19:34 EST
The "input" layer is fixed in the current linus tree to integrate proper with
the driver core. That message will go away then. Anyway you should disable
/proc/sys/kernel/hotplug completely when you sync up to that kernel version.
Later udevd versions work with netlink only and don't accept /sbin/hotplug
messages anymore.
Comment 2 Harald Hoyer 2006-01-24 10:40:50 EST
/proc/sys/kernel/hotplug is completly disabled now.