Bug 1725787

Summary: YafaRay fails to build with Python 3.8
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: YafaRayAssignee: Luya Tshimbalanga <luya_tfz>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: luya_tfz, negativo17, pviktori, vstinner
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: YafaRay-3.3.0-24.20190819git0a182c1.fc30 YafaRay-3.3.0-24.20190819git0a182c1.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-06 12:31:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1686977    

Description Miro Hrončok 2019-07-01 12:58:00 UTC
YafaRay fails to build with Python 3.8.0b1:

PYTHON_wrap.cxx:5223:1: error: cannot convert 'std::nullptr_t' to 'Py_ssize_t' {aka 'long int'} in initialization

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.8/fedora-rawhide-x86_64/00951672-YafaRay/

For all our attempts to build YafaRay with Python 3.8, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.8/package/YafaRay/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.8:
https://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Let us know here if you have any questions.

Comment 1 Victor Stinner 2019-07-01 13:12:25 UTC
> https://copr-be.cloud.fedoraproject.org/results/@python/python3.8/fedora-rawhide-x86_64/00951672-YafaRay/

Extract:

BUILDSTDERR: cd /builddir/build/BUILD/Core-67f658698ad46d9cc0b69288782aa2ffe4c8bcf1/src/xml_loader && /usr/builddir/build/BUILD/Core-67f658698ad46d9cc0b69288782aa2ffe4c8bcf1/src/bindings/yafaray_v3_interfacePYTHON_wrap.cxx:5223:1: error: cannot convert 'std::nullptr_t' to 'Py_ssize_t' {aka 'long int'} in initialization
BUILDSTDERR:  5223 | };
BUILDSTDERR:       | ^
BUILDSTDERR: make[2]: *** [src/bindings/CMakeFiles/_yafaray_v3_interface.dir/build.make:70: src/bindings/CMakeFiles/_yafaray_v3_interface.dir/yafaray_v3_interfacePYTHON_wrap.cxx.o] Error 1

Source file:
https://github.com/YafaRay/Core/blob/master/src/bindings/yafaray_v3_interface.i

Oh, it looks like a SWIG binding. Maybe SWIG isn't fully compatible with Python 3.8.

Comment 2 Luya Tshimbalanga 2019-07-01 19:29:23 UTC
Filed the issue upstream: http://www.yafaray.org/node/831

Comment 3 Petr Viktorin 2019-07-02 11:09:38 UTC
In Python 3.8, the reserved "tp_print" slot was changed from a function pointer to a number, `Py_ssize_t tp_vectorcall_offset`.
In C, there is no "nullptr"; either a 0 or NULL casts automatically to both pointers and numbers.

Please use 0 instead of "nullptr" in the slot to be source-compatible both with Python 3.8 and previous versions.


Upstream PR: https://github.com/YafaRay/Core/pull/114

Comment 4 Ben Cotton 2019-08-13 16:49:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 5 Miro Hrončok 2019-08-14 22:24:35 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 6 Miro Hrončok 2019-08-21 16:35:20 UTC
The f32-python side tag has been merged. In order to rebuild the package, do it in regular rawhide, but please wait until python3-3.8 is tagged:

  $ koji wait-repo f32-build --build python3-3.8.0~b3-3.fc32


If your built already started in f32-python, after it is finished, please tag it to rawhide with:

  $ koji tag-build f32-pending <nvr>

For example:

  $ koji tag-build f32-pending libreoffice-6.3.0.4-3.fc32

Thanks!

(This comment is mass posted to all bugzillas blocking the PYTHON38 tracking bug.)

Comment 7 Miro Hrončok 2019-08-21 17:29:22 UTC
(Python 3.8 has landed in the rawhide buildroot.)

Comment 8 Fedora Update System 2019-08-27 05:06:11 UTC
FEDORA-2019-40fb09930a has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40fb09930a

Comment 9 Fedora Update System 2019-08-30 00:03:52 UTC
YafaRay-3.3.0-24.20190819git0a182c1.fc30, blender-2.80-7.fc30, embree-3.6.0-0.4.beta.fc30, ispc-1.12.0-1.fc30, luxcorerender-2.2-0.6.beta3.fc30, openvdb-6.1.0-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40fb09930a

Comment 10 Fedora Update System 2019-08-30 00:25:01 UTC
YafaRay-3.3.0-24.20190819git0a182c1.fc29, blender-2.80-5.fc29, embree-3.6.0-0.4.beta.fc29, ispc-1.12.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-420e0ae4d4

Comment 11 Fedora Update System 2019-09-06 12:31:18 UTC
YafaRay-3.3.0-24.20190819git0a182c1.fc30, blender-2.80-7.fc30, embree-3.6.0-0.4.beta.fc30, ispc-1.12.0-1.fc30, luxcorerender-2.2-0.6.beta3.fc30, openvdb-6.1.0-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-09-06 12:58:14 UTC
YafaRay-3.3.0-24.20190819git0a182c1.fc29, blender-2.80-5.fc29, embree-3.6.0-0.4.beta.fc29, ispc-1.12.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.