Bug 1726823

Summary: insights-client --display-name returns 404 when routed through satellite
Product: Red Hat Satellite Reporter: Mike McCune <mmccune>
Component: RH Cloud - InsightsAssignee: Rex White <rexwhite>
Status: CLOSED ERRATA QA Contact: Radovan Drazny <rdrazny>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.3.5CC: egolov, ktordeur, lphiri, molasaga, peter.vreman, zhunting
Target Milestone: 6.5.2Keywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: tfm-rubygem-redhat_access-2.2.6-1.el7sat Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1708295 Environment:
Last Closed: 2019-08-06 14:37:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 3 Radovan Drazny 2019-07-24 11:57:27 UTC
Verified on the Sat 6.5.2 Snap.

$ insights-client --register
You successfully registered 88aa0d7c-eb30-4620-ba0f-1857a6cb8559 to account 5779551.
Successfully registered host rhel7-client.example.com
Automatic scheduling for Insights has been enabled.
Starting to collect Insights data for rhel7-client.example.com
Uploading Insights data.
Successfully uploaded report from rhel7-client.example.com to account 5779551.
$ insights-client --status
System is registered locally via .registered file. Registered at 2019-07-24T13:49:46.177407
Insights API confirms registration.
$ insights-client --display-name="WhatWasTheBugAgain?"
System display name changed from None to WhatWasTheBugAgain?

The new name is correctly displayed on the Insights Inventory page.

VERIFIED

Comment 5 errata-xmlrpc 2019-08-06 14:37:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2363