Bug 1727275

Summary: Openstack provider data not getting loaded with "no implicit conversion of String into Integer" error
Product: Red Hat CloudForms Management Engine Reporter: Yadnyawalk Tale <ytale>
Component: ProvidersAssignee: Marek Aufart <maufart>
Status: CLOSED CURRENTRELEASE QA Contact: Shveta <sshveta>
Severity: urgent Docs Contact: Red Hat CloudForms Documentation <cloudforms-docs>
Priority: high    
Version: 5.11.0CC: bmidwood, dmetzger, hkataria, iovadia, jfrey, jhardy, lavenel, mpovolny, obarenbo, simaishi, sshveta
Target Milestone: GAKeywords: Regression
Target Release: 5.11.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: openstack,v2v
Fixed In Version: 5.11.0.19 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-12-13 14:57:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: Bug
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Openstack Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1669240, 1685948    

Comment 7 Yadnyawalk Tale 2019-07-25 14:34:48 UTC
*** Bug 1733261 has been marked as a duplicate of this bug. ***

Comment 8 CFME Bot 2019-08-05 08:21:16 UTC
New commit detected on ManageIQ/manageiq-providers-openstack/master:

https://github.com/ManageIQ/manageiq-providers-openstack/commit/bfc90c14b5f67ef32697255b6f96a8ef51b686e5
commit bfc90c14b5f67ef32697255b6f96a8ef51b686e5
Author:     Marek Aufart <maufart@redhat.com>
AuthorDate: Mon Jul  8 06:06:45 2019 -0400
Commit:     Marek Aufart <maufart@redhat.com>
CommitDate: Mon Jul  8 06:06:45 2019 -0400

    Fix block_device_mapping in Snapshots Refresh

    OpenStack can return array for block_device_mapping on a VM,
    updating code to use first element if an Array is provided.

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1727275

 app/models/manageiq/providers/openstack/inventory/parser/cloud_manager.rb | 4 +-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comment 9 Ido Ovadia 2019-08-06 15:13:21 UTC
Reproduced to me on:
====================
CFME 5.11.0.17 
OSP 10

Comment 10 Yadnyawalk Tale 2019-08-07 13:39:12 UTC
5.11.0.18 too with OSP 13. ;)

Comment 11 Marek Aufart 2019-08-07 13:47:53 UTC
5.11.0.18 doesn't contain the fix, PR marked for backport to 5.11/I-branch.

Comment 12 CFME Bot 2019-08-07 22:21:20 UTC
New commit detected on ManageIQ/manageiq-providers-openstack/ivanchuk:

https://github.com/ManageIQ/manageiq-providers-openstack/commit/affb6d403ad0c283e037de1f3050b5c0385eca24
commit affb6d403ad0c283e037de1f3050b5c0385eca24
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Mon Aug  5 04:19:15 2019 -0400
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Mon Aug  5 04:19:15 2019 -0400

    Merge pull request #482 from aufi/fix_refresh_arr_snapshots_dev

    Fix block_device_mapping in Snapshots Refresh

    (cherry picked from commit 8cb6838ead4dfb982dada99261caf6b29bff68ff)

    https://bugzilla.redhat.com/show_bug.cgi?id=1727275

 app/models/manageiq/providers/openstack/inventory/parser/cloud_manager.rb | 4 +-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comment 13 Shveta 2019-08-16 06:07:41 UTC
Fixed in  5.11.0.19.20190813184334_ed72c9f