Bug 1727756 (CVE-2019-13233)

Summary: CVE-2019-13233 kernel: use-after-free in arch/x86/lib/insn-eval.c
Product: [Other] Security Response Reporter: Dhananjay Arunesh <darunesh>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: acaringi, airlied, bhu, blc, brdeoliv, bskeggs, dhoward, dvlasenk, esammons, fhrbata, hdegoede, hkrzesin, iboverma, ichavero, itamar, jarodwilson, jeremy, jforbes, jglisse, jlelli, john.j5live, jonathan, josef, jross, jstancek, jwboyer, kernel-maint, kernel-mgr, labbott, lgoncalv, linville, matt, mchehab, mcressma, mjg59, mlangsdo, nmurray, plougher, rt-maint, rvrbovsk, steved, williams
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
A vulnerability was found in the arch/x86/lib/insn-eval.c function in the Linux kernel. An attacker could corrupt the memory due to a flaw in use-after-free access to an LDT entry caused by a race condition between modify_ldt() and a #BR exception for an MPX bounds violation.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-06 00:53:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1728558, 1728559, 1727757, 1728560, 1728561    
Bug Blocks: 1727758    

Description Dhananjay Arunesh 2019-07-08 06:15:07 UTC
A vulnerability was found in arch/x86/lib/insn-eval.c in the Linux kernel, there is a
use-after-free for access to an LDT entry because of a race condition between
modify_ldt() and a #BR exception for an MPX bounds violation.

Reference:
https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.1.9
https://bugs.chromium.org/p/project-zero/issues/detail?id=1879

Upstream commit:
https://github.com/torvalds/linux/commit/de9f869616dd95e95c00bdd6b0fcd3421e8a4323
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=de9f869616dd95e95c00bdd6b0fcd3421e8a4323

Comment 1 Dhananjay Arunesh 2019-07-08 06:15:24 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 1727757]

Comment 2 Justin M. Forbes 2019-07-08 12:40:32 UTC
This was fixed for Fedora with the 5.1.9 stable updates.

Comment 8 errata-xmlrpc 2019-11-05 20:35:38 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2019:3309 https://access.redhat.com/errata/RHSA-2019:3309

Comment 9 errata-xmlrpc 2019-11-05 21:06:20 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2019:3517 https://access.redhat.com/errata/RHSA-2019:3517

Comment 10 Product Security DevOps Team 2019-11-06 00:53:00 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-13233