Bug 1727901

Summary: [3.9] docker container install failed on RHEL 7.7 RC
Product: OpenShift Container Platform Reporter: Weihua Meng <wmeng>
Component: InstallerAssignee: Russell Teague <rteague>
Installer sub component: openshift-ansible QA Contact: Weihua Meng <wmeng>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: bleanhar, rteague, vrutkovs, wsun, xxia
Version: 3.9.0   
Target Milestone: ---   
Target Release: 3.9.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-26 16:27:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1702415    

Description Weihua Meng 2019-07-08 13:17:41 UTC
Description of problem:
docker container install failed on RHEL 7.7 RC 
kernel-3.10.0-1060.el7.x86_64
python-2.7.5-86.el7.x86_64

install success on RHEL 7.6
kernel-3.10.0-957.21.3.el7.x86_64
python-2.7.5-80.el7_6.x86_64

Version-Release number of the following components:
openshift-ansible-3.9.89-1.git.0.b060ff8.el7

How reproducible:
Always

Steps to Reproduce:
1. docker container install OCP 3.9 on RHEL 7.7 RC

Actual results:
install failed.
TASK [openshift_cli : Copy client binaries/symlinks out of CLI image for use on the host] ***
Monday 08 July 2019  20:48:10 +0800 (0:00:00.797)       0:02:46.202 *********** 
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: IOError: [Errno 2] No such file or directory: '/tmp/tmpXhngI4/openshift'
fatal: [ci-vm-10-0-150-117.hosted.upshift.rdu2.redhat.com]: FAILED! => {"changed": false, "failed": true, "module_stderr": "Traceback (most recent call last):\n  File \"/tmp/ansible_AEDG1F/ansible_module_openshift_container_binary_sync.py\", line 205, in <module>\n    main()\n  File \"/tmp/ansible_AEDG1F/ansible_module_openshift_container_binary_sync.py\", line 196, in main\n    binary_syncer.sync()\n  File \"/tmp/ansible_AEDG1F/ansible_module_openshift_container_binary_sync.py\", line 48, in sync\n    return self._sync_docker()\n  File \"/tmp/ansible_AEDG1F/ansible_module_openshift_container_binary_sync.py\", line 95, in _sync_docker\n    self._sync_binaries()\n  File \"/tmp/ansible_AEDG1F/ansible_module_openshift_container_binary_sync.py\", line 101, in _sync_binaries\n    self._sync_binary('openshift')\n  File \"/tmp/ansible_AEDG1F/ansible_module_openshift_container_binary_sync.py\", line 144, in _sync_binary\n    shutil.move(src_path, dest_path)\n  File \"/usr/lib64/python2.7/shutil.py\", line 301, in move\n    copy2(src, real_dst)\n  File \"/usr/lib64/python2.7/shutil.py\", line 130, in copy2\n    copyfile(src, dst)\n  File \"/usr/lib64/python2.7/shutil.py\", line 82, in copyfile\n    with open(src, 'rb') as fsrc:\nIOError: [Errno 2] No such file or directory: '/tmp/tmpXhngI4/openshift'\n", "module_stdout": "", "msg": "MODULE FAILURE", "rc": 1}


Expected results:
install success.

on RHEL 7.6,
TASK [openshift_cli : Copy client binaries/symlinks out of CLI image for use on the host] ***
Monday 08 July 2019  18:10:43 +0800 (0:00:00.655)       0:02:19.319 *********** 
changed: [ci-vm-10-0-151-165.hosted.upshift.rdu2.redhat.com] => {"changed": true, "failed": false, "output": ["61b139f438a5ee671c2300eefc90ae7aa83b5d62f26733494612c57366fa1a72\n", "Using temp dir: /tmp/tmpf4CgUt", "Moved /tmp/tmpf4CgUt/openshift to /usr/local/bin/openshift.", "Moved /tmp/tmpf4CgUt/oc to /usr/local/bin/oc.", "Symlinked /usr/local/bin/kubectl to /usr/local/bin/oc."]}

Comment 7 Weihua Meng 2019-08-02 09:13:09 UTC
Install success with openshift-ansible-3.9.91-1.git.0.03df448.el7 on the latest RHEL 7.7 RC, RC3

RHEL 7.7 RC build has updated from RC1 to RC3,
kernel updated from kernel-3.10.0-1060.el7.x86_64 to kernel-3.10.0-1062.el7.x86_64

Install failed 25 days ago with openshift-ansible-3.9.89-1.git.0.b060ff8.el7 on RHEL 7.7 RC1, 
success with openshift-ansible-3.9.91-1.git.0.03df448.el7 on latest RHEL 7.7 RC3, 
so I move the status to verified.

Comment 9 errata-xmlrpc 2019-08-26 16:27:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2550