Bug 1728837

Summary: python2-qscintilla: FTBFS on f31+, Fatal Python error: PyQt5.QtCore: Unable to embed qt.conf
Product: [Fedora] Fedora Reporter: Rex Dieter <rdieter>
Component: qscintillaAssignee: Rex Dieter <rdieter>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: kde-sig, mads, ndbecker2, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-07 13:47:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1736914, 1737547    

Description Rex Dieter 2019-07-10 18:21:20 UTC
Trying to build python2 qscintilla bindings recently started to fail in rawhide (see also bug #1728266)  )during configure step,


+ /usr/bin/python2 configure.py --verbose --pyqt=PyQt5 --sip=/usr/bin/sip-pyqt5 --qsci-incdir=../Qt5 --qsci-libdir=../Qt5 --no-dist-info
BUILDSTDERR: Fatal Python error: PyQt5.QtCore: Unable to embed qt.conf
BUILDSTDERR: /var/tmp/rpm-tmp.TzvxVo: line 126: 29317 Aborted                 (core dumped) /usr/bin/python2 configure.py --verbose --pyqt=PyQt5 --sip=/usr/bin/sip-pyqt5 --qsci-incdir=../Qt5 --qsci-libdir=../Qt5 --no-dist-info

To unblock python-3.8 update for f31, I'm (hopefully) temporarily disabling python2 support in qscintilla at least until this is resolved.

Comment 1 Rex Dieter 2019-07-10 18:23:09 UTC
cc'ing hgview maintainers

Comment 2 Rex Dieter 2019-07-10 18:23:37 UTC
cc'ing tortoisehg maintainers

Comment 3 Mads Kiilerich 2019-08-07 00:40:13 UTC
Seems to be fixed now? Thanks!

Comment 4 Rex Dieter 2019-08-07 13:47:25 UTC
Nod, it was a bug in PyQt5, fixed in latest 5.13.0 build