Bug 1729871

Summary: thai-scalable-waree-fonts lacks fontconfig .conf file
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: thai-scalable-fontsAssignee: Peng Wu <pwu>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 30CC: i18n-bugs, petersen, pwu, tagoh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: thai-scalable-fonts-0.6.5-5.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-07-26 00:59:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jens Petersen 2019-07-15 07:51:04 UTC
Description of problem:
thai-scalable-waree-fonts is the current default font for Thai in Fedora
(or should be) but it is missing a .conf file, so actually it is not used
but instead Google Droid Sans Thai is used.

Version-Release number of selected component (if applicable):
thai-scalable-waree-fonts-0.6.5-3.fc30

How reproducible:
100%

Steps to Reproduce:
1. fc-match :lang=th

Actual results:
DroidSansThai.ttf: "Droid Sans" "Regular"

Expected results:
Waree.ttf

Comment 1 Fedora Update System 2019-07-15 09:56:37 UTC
FEDORA-2019-96efa391f7 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-96efa391f7

Comment 2 Fedora Update System 2019-07-16 00:54:11 UTC
thai-scalable-fonts-0.6.5-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-96efa391f7

Comment 3 Akira TAGOH 2019-07-16 04:53:17 UTC
Assigning one typeface to multiple aliases is basically wrong. particularly sans-serif and serif is different one. apparently Waree font looks like sans-serif. we should have different one for serif.

Comment 4 Fedora Update System 2019-07-17 07:48:53 UTC
FEDORA-2019-96efa391f7 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-96efa391f7

Comment 5 Peng Wu 2019-07-17 07:53:09 UTC
Okay, I updated the build to use Waree for sans-serif and Norasi for serif.

Comment 6 Fedora Update System 2019-07-18 00:42:19 UTC
thai-scalable-fonts-0.6.5-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-96efa391f7

Comment 7 Fedora Update System 2019-07-26 00:59:30 UTC
thai-scalable-fonts-0.6.5-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.