Bug 1729992

Summary: switch from langpacks to langpacks-core
Product: [Fedora] Fedora Reporter: Parag Nemade <pnemade>
Component: glibcAssignee: Carlos O'Donell <codonell>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 31CC: aoliva, arjun.is, codonell, dj, fweimer, law, mfabian, petersen, pfrankli, rth, siddhesh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glibc-2.30-5.fc31 glibc-2.30.9000-8.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-28 00:03:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Parag Nemade 2019-07-15 14:01:22 UTC
Description of problem:

As part of F31 https://fedoraproject.org/wiki/Changes/Langpacks-core Change implementation, I was thinking if glibc.spec can drop
Supplements: (glibc and (]]..suppl..[[))
and langpacks.spec to have
Requires: glibc-langpack-<locale>

I see glibc langpack packages (198 on F30) are more whereas not every such have corresponding langpacks meta-packages (88 on F30)

Version-Release number of selected component (if applicable):
latest glibc package

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
glibc.spec is supplementing for langpacks-<locale>

Expected results:
langpacks.spec to requires glibc langpack packages

Additional info:

Comment 1 Parag Nemade 2019-07-24 12:57:09 UTC
Can I request glibc package maintainers to provide their feedback on this request?

Comment 2 Florian Weimer 2019-07-24 13:13:12 UTC
I do not have an opinion on this change.

Would this change here help with bug 1380069 as well?  Would it make that fix more difficult.

Comment 3 Parag Nemade 2019-07-26 09:42:16 UTC
Well, I tried to test this in my copr with new langpacks-2.0 package but looks like glibc-langpack-<langcode> is not getting removed. Will check more on this.

Comment 4 Jens Petersen 2019-07-30 07:02:05 UTC
(In reply to Florian Weimer from comment #2)
> I do not have an opinion on this change.

To add a little more: further glibc doesn't actually know what meta langpacks packages exist in Fedora.
So in this sense it makes more sense to carry the information in langpacks rather than glibc itself.

> Would this change here help with bug 1380069 as well?  Would it make that
> fix more difficult.

I don't think it has any affect on that, but maybe 'glibc-langpack' can be simplified anyway.

Comment 5 Ben Cotton 2019-08-13 18:52:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 6 Jens Petersen 2019-09-16 10:57:19 UTC
We really need changes for langpacks-core-* at the very least for F31.

https://src.fedoraproject.org/rpms/glibc/pull-request/15
https://src.fedoraproject.org/rpms/glibc/pull-request/16

I would still rather we moved this completely to langpacks since that is more consistent.

Comment 7 Fedora Update System 2019-09-26 13:49:36 UTC
FEDORA-2019-3bf71b86ec has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3bf71b86ec

Comment 8 Fedora Update System 2019-09-27 02:29:06 UTC
glibc-2.30-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3bf71b86ec

Comment 9 Fedora Update System 2019-09-28 00:03:07 UTC
glibc-2.30-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Jens Petersen 2019-09-28 04:06:27 UTC
Thanks

For F32 we want to move the weak dependencies into the langpacks package.