Bug 1730034

Summary: rteval triggers exception and prints traceback on bare-metal
Product: Red Hat Enterprise Linux 7 Reporter: Nitesh Narayan Lal <nilal>
Component: rtevalAssignee: John Kacur <jkacur>
Status: CLOSED ERRATA QA Contact: Qiao Zhao <qzhao>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.8CC: bhu, jkacur, lcapitulino, lgoncalv, mstowell, pezhang
Target Milestone: rc   
Target Release: 7.8   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1766879 (view as bug list) Environment:
Last Closed: 2020-03-31 20:03:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1672377, 1715542, 1766879    
Attachments:
Description Flags
pass node argument as string to Popen in hackbench.py none

Description Nitesh Narayan Lal 2019-07-15 16:07:35 UTC
Description of problem:
rteval triggers exception and prints a traceback while running on bare-metal.

Version-Release number of selected component (if applicable):
rteval: 2.14-12.el7
kernel: 3.10.0-1040.rt56.999.el7.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install kernel-rt and rteval. 
2. Execute "rteval --onlyload --duration=1m --verbose"
3. Check the console output.

Actual results:
Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 812, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.7/site-packages/rteval/modules/__init__.py", line 195, in run
    raise RuntimeError()
RuntimeError


Expected results:
rteval starts and doesn't print any traceback.

Additional info:

Comment 6 John Kacur 2019-12-03 18:46:07 UTC
The problem is caused by missing software requires needed to compile the kernel which is done by kcompile.py to put a stress / load on the machine while measuring real-time performances.

This is a safe change even now, since the only change is to the spec file in the form of Requires

Comment 15 John Kacur 2019-12-05 12:23:00 UTC
it seems that we need to ensure that the node argument to Popen is passed as a string here as well.

Comment 16 John Kacur 2019-12-05 12:24:41 UTC
Created attachment 1642350 [details]
pass node argument as string to Popen in hackbench.py

Comment 22 errata-xmlrpc 2020-03-31 20:03:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1118