Bug 1730655

Summary: 51-dracut-rescue-postinst.sh adds a Rescue entry that will become the default if saved_entry is not set
Product: Red Hat Enterprise Linux 7 Reporter: Welterlen Benoit <bwelterl>
Component: grubbyAssignee: Bootloader engineering team <bootloader-eng-team>
Status: CLOSED WONTFIX QA Contact: Release Test Team <release-test-team>
Severity: high Docs Contact:
Priority: unspecified    
Version: 7.6CC: bwelterl, dracut-maint-list, kholtz, marjones, mzheng, rblakley
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-08-27 15:42:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Welterlen Benoit 2019-07-17 09:34:56 UTC
Description of problem:
A customer faced the situation where an upgrade of the kernel set the default grub entry to the Rescue. 
I think that even if there is no saved_entry, the Rescue should be put under any other entry. 

Version-Release number of selected component (if applicable):
- RHEL 7
- dracut-config-rescue-033-554.el7.x86_64

How reproducible:
Always if:
- The issue is the combination of 2 situations:
- no /etc/machine-id (or new one created for any reason, that does not match the rescue initramfs in /boot)
- no saved_entry in grubenv

Steps to Reproduce:
1. rm /etc/machine-id
2. delete saved_entry in grubenv
3. update kernel

Actual results:
The default entry is the Rescue one.

Expected results:
The default entry should be the new kernel installed

Additional info:

Comment 3 Lukáš Nykrýn 2019-07-30 13:08:05 UTC
I am not sure that dracut can influence that. new-kernel-pkg belongs to grubby, so let's try it there.

Comment 8 Tomas Popela 2020-08-27 14:42:44 UTC
Closing the bug as the attached customer case is closed.