Bug 1731187

Summary: [3.11] master-controllers log spammed with "The resourceVersion for the provided watch is too old." warning messages
Product: OpenShift Container Platform Reporter: Eric Rich <erich>
Component: kube-controller-managerAssignee: Jack Ottofaro <jack.ottofaro>
Status: CLOSED ERRATA QA Contact: zhou ying <yinzhou>
Severity: high Docs Contact:
Priority: high    
Version: 3.9.0CC: agawand, andreas.gegenleitner, ansverma, aos-bugs, jack.ottofaro, jernej.vodopivec, jkaur, jlee, joe, jokerman, karel.klic, mfojtik, mharri, mjahangi, mmccomas, nagrawal, nnosenzo, pamoedom, per.carlson, rgregory, somalley, stwalter, wmeng, xxia
Target Milestone: ---   
Target Release: 3.11.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Warning message reported by etcd roughly every 7 seconds Consequence: Excessive logging. Fix: Changed log level to info.
Story Points: ---
Clone Of: 1573460 Environment:
Last Closed: 2019-09-03 15:56:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1573460, 1731188    

Comment 1 Jack Ottofaro 2019-07-18 20:39:57 UTC
PR created https://github.com/openshift/origin/pull/23429

Comment 3 zhou ying 2019-08-28 02:53:41 UTC
Confirmed with latest version: v3.11.141, the most warnings have updated with information:
oc logs -f po/master-controllers-ip-172-18-4-110.ec2.internal -n kube-system |grep -i "The resourceVersion for the provided watch is too old"
I0827 22:12:40.924969       1 reflector.go:274] k8s.io/client-go/informers/factory.go:130: watch of *v1.PersistentVolume ended with: The resourceVersion for the provided watch is too old.
I0827 22:13:03.715422       1 reflector.go:274] k8s.io/client-go/informers/factory.go:130: watch of *v1beta1.PodDisruptionBudget ended with: The resourceVersion for the provided watch is too old.
I0827 22:13:12.610513       1 reflector.go:274] k8s.io/client-go/informers/factory.go:130: watch of *v1.Role ended with: The resourceVersion for the provided watch is too old.
I0827 22:13:13.914191       1 reflector.go:274] k8s.io/client-go/informers/factory.go:130: watch of *v1.ResourceQuota ended with: The resourceVersion for the provided watch is too old.
I0827 22:13:15.819708       1 reflector.go:274] k8s.io/client-go/informers/factory.go:130: watch of *v1.ClusterRoleBinding ended with: The resourceVersion for the provided watch is too old.
I0827 22:13:16.823143       1 reflector.go:274] k8s.io/client-go/informers/factory.go:130: watch of *v1beta1.CronJob ended with: The resourceVersion for the provided watch is too old.

Comment 5 errata-xmlrpc 2019-09-03 15:56:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2580