Bug 1731554

Summary: multisite: radosgw-admin bucket sync status incorrectly reports "caught up" during full sync
Product: Red Hat Ceph Storage Reporter: John Harrigan <jharriga>
Component: RGW-MultisiteAssignee: Casey Bodley <cbodley>
Status: CLOSED ERRATA QA Contact: Tejas <tchandra>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.2CC: assingh, ceph-eng-bugs, ceph-qe-bugs, hyelloji, mbenjamin, tserlin, vumrao
Target Milestone: rcFlags: hyelloji: needinfo-
Target Release: 4.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ceph-14.2.8-3.el8, ceph-14.2.8-3.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-19 17:30:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1727980    

Description John Harrigan 2019-07-19 18:17:26 UTC
Description of problem:
If no shards on incremental sync are behind, but some shards are still on full sync, the 'radosgw-admin bucket sync status' command should not report that the "bucket is caught up with source".

Version-Release number of selected component (if applicable):
RHCS 3.2z1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 8 errata-xmlrpc 2020-05-19 17:30:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:2231