Bug 1731638

Summary: python-livereload no more provides "livereload"
Product: [Fedora] Fedora Reporter: Anton Guda <atu>
Component: python-livereloadAssignee: Fabian Affolter <mail>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 31CC: edgar.hoch, mail, williamjmorenor
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-13 20:03:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Anton Guda 2019-07-20 08:10:37 UTC
Description of problem:
None of the python-livereload subpackages provides "livereload",
which is really provided by python-livereload-livereload,
and required by mkdocs.

Version-Release number of selected component (if applicable):
python-livereload-2.6.1-1

How reproducible:
Always


Steps to Reproduce:
1. Try to update:
rpm -Uvh --test python-livereload-docs-2.6.1-1.fc31.noarch.rpm python-livereload-livereload-2.6.1-1.fc31.noarch.rpm python3-livereload-2.6.1-1.fc31.noarch.rpm


Actual results:
error: Failed dependencies:
livereload is needed by (installed) mkdocs-0.16.3-9.fc30.noarch

Expected results:
Clean update

Comment 1 Fedora Update System 2019-07-20 13:56:13 UTC
FEDORA-2019-02fb8a1a8d has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-02fb8a1a8d

Comment 2 Anton Guda 2019-07-20 16:32:42 UTC
Build python-livereload-2.6.1-2.fc31 works for me.
Bug can be closed.

Comment 3 Fedora Update System 2019-07-21 01:00:08 UTC
python-livereload-2.6.1-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-02fb8a1a8d

Comment 4 Ben Cotton 2019-08-13 17:10:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 5 Ben Cotton 2019-08-13 18:59:32 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 6 Edgar Hoch 2019-09-23 22:32:59 UTC
Please build python-livereload-2.6.1-1 for Fedora 30, too. There is the same dependency problem in Fedora 30.

Simply rebuild package python-livereload-2.6.1-6.fc32.src.rpm (from koji) for Fedora 30 would solve the dependency problem.