Bug 1731677

Summary: PATCH: Add sip-doc documentation subpackage
Product: [Fedora] Fedora Reporter: "FeRD" (Frank Dana) <ferdnyc>
Component: sipAssignee: Than Ngo <than>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: kde-sig, rdieter, than
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-20 13:51:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Specfile patch to add documentation subpackage
none
Specfile patch to add documentation subpackage (revised) none

Description "FeRD" (Frank Dana) 2019-07-21 07:20:51 UTC
Created attachment 1592399 [details]
Specfile patch to add documentation subpackage

Description of problem:
The sip distribution includes a full set of documentation in the doc/html directory, none of which is available in the RPMs.

Version-Release number of selected component (if applicable):
sip-4.19.17-1.fc30.x86_64

Additional info:
Here's a specfile patch that builds a sip-doc subpackage, containing a copy of the source distribution's doc/html directory placed in /usr/share/doc/sip/html

I tried to submit this as a pull request for rpms/sip in Pagure, but Open PR shows a "Pull-request have been disabled for this repo" message. So, attached is a git format-patch version of the PR.

(Note: I also updated the package URL to https, and dropped the "www." prefix that riverbank's server is no longer using.)

(Note2: The spec changes copy the documentation files "manually" using find, instead of using %doc in the files section, because when I used %doc the docs were installed to /usr/share/doc/sip-doc/html/ which doesn't seem like the desirable outcome. If there's a way around that, please let me know and I'll correct the patch.)

Comment 1 Ben Cotton 2019-08-13 16:50:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Ben Cotton 2019-08-13 18:59:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 "FeRD" (Frank Dana) 2020-04-20 06:10:00 UTC
Created attachment 1680192 [details]
Specfile patch to add documentation subpackage (revised)

@rdieter:

Here's a current, slightly-improved version of that patch, in fact, made against the current master branch.

Comment 4 Rex Dieter 2020-04-20 13:51:57 UTC
Patch applied thanks