Bug 1732176

Summary: systemd-networkd on Fedora 30 does not work with Linux 5.2
Product: [Fedora] Fedora Reporter: Hristo Venev <hristo>
Component: systemdAssignee: systemd-maint
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: lnykryn, msekleta, ssahani, s, systemd-maint, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-05 21:07:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Hristo Venev 2019-07-22 21:49:47 UTC
Description of problem:
systemd-networkd cannot bring network interfaces up on Linux 5.2 (fails with EINVAL)

Version-Release number of selected component (if applicable):
systemd-241-9.gitb67ecf2.fc30.x86_64

How reproducible:
Fully

Steps to Reproduce:
1. Configure systemd-networkd
2. Install Linux 5.2.2
3. Boot

Actual results:
systemd-networkd fails to bring network interfaces up

Expected results:
systemd-networkd brings network interfaces up

Additional info:
Fixed in systemd commit 4eb086a38712ea98faf41e075b84555b11b54362, systemd-stable 242 commit 8fbc72f45f4aa84889bc8694a9ce662946464c37.

Commit 9f6e82e6eb3b6e73d66d00d1d6eee60691fb702f makes a lot of sense, so consider including it as well. It is also included in systemd-stable 242.

Comment 1 Zbigniew Jędrzejewski-Szmek 2019-08-05 21:07:47 UTC

*** This bug has been marked as a duplicate of bug 1718192 ***