Bug 1733515

Summary: Listing problems segfaults with 'abrt-cli list' command
Product: Red Hat Enterprise Linux 8 Reporter: Martin Kutlak <mkutlak>
Component: libreportAssignee: Martin Kutlak <mkutlak>
Status: CLOSED ERRATA QA Contact: Martin Kyral <mkyral>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 8.1CC: mkyral, msuchy
Target Milestone: rc   
Target Release: 8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libreport-2.9.5-9.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-05 22:36:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 2 Martin Kyral 2019-07-26 14:08:41 UTC
Backtrace:

#0  0x00007ffff658144e in __strcmp_avx2 () at /lib64/libc.so.6
#1  0x00007ffff6f81042 in pop_next_command () at /lib64/libreport.so.0
#2  0x00007ffff6f8187e in _list_possible_events () at /lib64/libreport.so.0
#3  0x00007ffff6f821bf in list_possible_events_problem_data_glist () at /lib64/libreport.so.0
#4  0x0000555555556e7f in print_crash (problem_data=problem_data@entry=0x55555579f060, detailed=detailed@entry=0, text_size=text_size@entry=4096) at list.c:102
#5  0x00005555555572a0 in print_crash_list (text_size=4096, until=0, since=0, only_not_reported=0, detailed=0, crash_list=0x7fffe00014a0) at list.c:165
#6  0x00005555555572a0 in cmd_list (argc=<optimized out>, argv=<optimized out>) at list.c:204
#7  0x000055555555681d in handle_internal_command (commands=0x7fffffffe100, argv=0x7fffffffe310, argc=1) at abrt-cli.c:104
#8  0x000055555555681d in main (argc=1, argv=<optimized out>) at abrt-cli.c:153

Comment 7 errata-xmlrpc 2019-11-05 22:36:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3663