Bug 1733673

Summary: [Feature Request] Add Desktop LiveCD images for ppc64le systems
Product: [Fedora] Fedora Reporter: Timothy Pearson <tpearson>
Component: LiveCDAssignee: Dan Horák <dan>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: unspecified    
Version: 31CC: dan, hannsj_uhl, jcajka
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: ppc64le   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-11 09:37:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1071880    

Description Timothy Pearson 2019-07-27 07:37:21 UTC
Description of problem:
Only a server install version of Fedora is available for ppc64le systems, despite hundreds of desktop systems (and growing) currently present in the wild.

Fedora should provide a live CD / desktop install ISO for ppc64le systems.  The ISO should contain common graphics drivers (amdgpu, ast, nouveau, etc.) to make installation of Fedora on the extant ppc64le desktops and workstations (Talos II / Blackbird / etc.) as easy as it is on x86.

Comment 1 Ben Cotton 2019-08-13 18:51:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 2 Dan Horák 2019-09-17 11:34:57 UTC
resolved via https://pagure.io/pungi-fedora/pull-request/755

Comment 3 Timothy Pearson 2020-01-10 05:46:31 UTC
Doesn't look like this actually made its way into F32 yet -- notably https://alt.fedoraproject.org/alt/ has CD images for aarch64 but NOT ppc64le yet.

Comment 4 Dan Horák 2020-01-10 08:56:27 UTC
Workstation Live image has been enabled for ppc64le, it's part of the daily compose process. It worked fine for a while, but it fails for some time now. It used to be due bug 1722181, now also bug 1784961 is against us.

Comment 5 Timothy Pearson 2020-01-10 17:27:55 UTC
Bug 1784961 looks like it's "just" QEMU.  Do you know if the builders are P8 or P9?  I've never actually seen a KVM guest just die like that before on P9, so am somewhat interested.

Comment 6 Dan Horák 2020-01-10 17:34:41 UTC
It's all P9, but doing nested virt. HW is carved into builder VMs and then the builders run a VM to create the images.

Comment 7 Timothy Pearson 2020-01-10 17:40:54 UTC
OK, good to know.  We use nested virt here as well, but haven't had it die on us.  That being said, we force the old XICS interrupt controllers for most of our VMs; given the XIVE warnings it could be worth passing ic-mode=xics to QEMU for a quick test.

Comment 8 Dan Horák 2020-01-10 18:09:21 UTC
yup, ic-mode=xics helps, as does -M pseries-4.0, so the well known issue ;-)

Comment 9 Timothy Pearson 2020-01-10 18:11:56 UTC
Good to know -- at least there's a path now to reenabling the image builds :)

Comment 10 Dan Horák 2020-01-11 09:37:27 UTC
Workstation Live ISO is back - https://koji.fedoraproject.org/koji/taskinfo?taskID=40398477, it was hitting only bug 1722181 and https://github.com/weldr/lorax/commit/c038bb53c60cd7e9e335dab1909f4884e30ad123 is the fix/workaround.