Bug 1733796

Summary: SELinux is preventing nutdrv_qx from using the 'signal' accesses on a process.
Product: [Fedora] Fedora Reporter: Danie de Jager <danie.dejager>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: dwalsh, lvrabec, mgrepl, plautrba, zpytela
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:d86b8218fe46dbc9407a125b77f2bd35d047250fb9b54a687153ac1caf5c2ee0;
Fixed In Version: selinux-policy-3.14.3-45.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-06 12:33:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Danie de Jager 2019-07-28 17:47:38 UTC
Description of problem:
SELinux is preventing nutdrv_qx from using the 'signal' accesses on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that nutdrv_qx should be allowed signal access on processes labeled unconfined_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'nutdrv_qx' --raw | audit2allow -M my-nutdrvqx
# semodule -X 300 -i my-nutdrvqx.pp

Additional Information:
Source Context                system_u:system_r:nut_upsdrvctl_t:s0
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                Unknown [ process ]
Source                        nutdrv_qx
Source Path                   nutdrv_qx
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-41.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.1.18-300.fc30.x86_64 #1 SMP Mon
                              Jul 15 15:42:34 UTC 2019 x86_64 x86_64
Alert Count                   1
First Seen                    2019-07-28 19:36:39 SAST
Last Seen                     2019-07-28 19:36:39 SAST
Local ID                      c990166d-4eba-4de5-a93d-febca1630484

Raw Audit Messages
type=AVC msg=audit(1564335399.512:28253): avc:  denied  { signal } for  pid=14771 comm="nutdrv_qx" scontext=system_u:system_r:nut_upsdrvctl_t:s0 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process permissive=0


Hash: nutdrv_qx,nut_upsdrvctl_t,unconfined_t,process,signal

Version-Release number of selected component:
selinux-policy-3.14.3-41.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.1.18-300.fc30.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2019-07-29 12:24:49 UTC
*** Bug 1733795 has been marked as a duplicate of this bug. ***

Comment 2 Lukas Vrabec 2019-07-29 13:14:45 UTC
commit 0e469ccdc799d835dda6b14d1719534d07a789a1 (HEAD -> rawhide)
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Mon Jul 29 15:11:58 2019 +0200

    Allow nut services to communicate with unconfined domains
    
    Resolves: rhbz#1733795

Comment 3 Fedora Update System 2019-09-05 06:52:20 UTC
FEDORA-2019-be14ea0375 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-be14ea0375

Comment 4 Fedora Update System 2019-09-05 12:53:16 UTC
selinux-policy-3.14.3-45.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-be14ea0375

Comment 5 Fedora Update System 2019-09-06 12:33:52 UTC
selinux-policy-3.14.3-45.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.