Bug 1734374

Summary: Fedora CoreOS Installer ISO written to USB drive does not boot
Product: [Fedora] Fedora Reporter: Daniel Riek <riek>
Component: coreos-installerAssignee: Benjamin Gilbert <bgilbert>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: bgilbert, dustymabe, jonathan, jzehrarnyg, slowrie
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-07-31 15:45:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Daniel Riek 2019-07-30 11:52:53 UTC
Description of problem:
Writing the Fedora CoreOS Installer ISO to a USB stick does not yield a bootable image.

DD and Fedora Media Writer will write the image, but it won't boot. Gnome Disk Uitl complains that the image does not appear to be a live image or installer DVD.

Version-Release number of selected component (if applicable):
fedora-coreos-30.20190729.dev.0-installer.iso

How reproducible:
Always: Download installer iso, write to USB stick, try to boot in a machine.

Comment 1 Daniel Riek 2019-07-30 12:02:42 UTC
I am sorry, one correction: the complaint about the image not being a live image is from livecd-iso-to-disk, not the Gnome Disk Tool.

Comment 2 Benjamin Gilbert 2019-07-31 06:33:53 UTC
Thanks for the report!  Booting the ISO from a USB stick isn't working on BIOS systems because we aren't currently adding an MBR.  https://github.com/coreos/coreos-assembler/pull/677 should fix this.

livecd-iso-to-disk is not expected to work with Fedora CoreOS ISOs, since Fedora CoreOS doesn't lay out its ISO images in the way that livecd-iso-to-disk expects.

Comment 3 Benjamin Gilbert 2019-07-31 15:45:38 UTC
This should be fixed in an upcoming Fedora CoreOS release.