Bug 1734470

Summary: Reapply DHCPv6 only mode will still get autoconf.
Product: Red Hat Enterprise Linux 8 Reporter: Gris Ge <fge>
Component: NetworkManagerAssignee: Beniamino Galvani <bgalvani>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: high Docs Contact:
Priority: high    
Version: 8.1CC: atragler, bgalvani, edwardh, fgiudici, jmaxwell, lrintel, rkhan, sukulkar, thaller, till, toneata, vbenes
Target Milestone: rcKeywords: ZStream
Target Release: 8.2   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: NetworkManager-1.22.0-0.1.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1772820 (view as bug list) Environment:
Last Closed: 2020-04-28 16:53:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1738136, 1738101, 1738635, 1772820    
Attachments:
Description Flags
Reproduce script.
none
System logs with NM trace enabled
none
Script to check RA neigh parameters none

Description Gris Ge 2019-07-30 15:57:36 UTC
Created attachment 1594673 [details]
Reproduce script.

Description of problem:

When reapply the change of ipv6.method ignore -> dhcp, the autoconf
will got enabled after some seconds.

nmcli c add  type ethernet ifname dhcpcli \
    connection.id dhcpcli \
    ipv4.method disabled \
    ipv6.method ignore
nmcli c up dhcpcli

nmcli c modify dhcpcli ipv6.method dhcp
nmcli d reapply dhcpcli



Version-Release number of selected component (if applicable):
NetworkManager-1.20.0-0.3.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Download the attached script.
2. sudo bash ./nm_reapply_ipv6.sh
3.

Actual results:
autoconf routes show up at second 7, and disappear second 12, then show up again
at second 17:

Expected results:
No autoconf routes.

Additional info:

Comment 1 Gris Ge 2019-07-30 16:15:11 UTC
The output of reproduce scripts:

====
[fge@el8 ~]$ sudo ./nm_reapply_ipv6.sh
Error: unknown connection 'dhcpcli'.
Error: cannot delete unknown connection(s): 'dhcpcli'.
Cannot find device "dhcpcli"
radvd-2.17-12.el8.x86_64
0
0
Connection 'dhcpcli' (0816d2d0-b070-4d9b-b630-5e4cc806ec48) successfully added.
Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/3)
::1 dev lo proto kernel metric 256 pref medium
2001:db8:1::/64 dev dhcpsrv proto kernel metric 256 pref medium
fe80::/64 dev enp1s0 proto kernel metric 100 pref medium
fe80::/64 dev dhcpsrv proto kernel metric 256 pref medium
fe80::/64 dev dhcpcli proto kernel metric 256 pref medium
Connection successfully reapplied to device 'dhcpcli'.
1
2
3
default via fe80::b0ec:c5ff:fedd:b7b2 dev dhcpcli proto ra metric 1024 expires 299sec hoplimit 64 pref medium
4
default via fe80::b0ec:c5ff:fedd:b7b2 dev dhcpcli proto ra metric 1024 expires 298sec hoplimit 64 pref medium
5
default via fe80::b0ec:c5ff:fedd:b7b2 dev dhcpcli proto ra metric 1024 expires 297sec hoplimit 64 pref medium
6
default via fe80::b0ec:c5ff:fedd:b7b2 dev dhcpcli proto ra metric 1024 expires 296sec hoplimit 64 pref medium
7
default via fe80::b0ec:c5ff:fedd:b7b2 dev dhcpcli proto ra metric 1024 expires 295sec hoplimit 64 pref medium
8
9
10
11
12
13
14
15
16
17
default via fe80::b0ec:c5ff:fedd:b7b2 dev dhcpcli proto ra metric 1024 expires 299sec hoplimit 64 pref medium
18
default via fe80::b0ec:c5ff:fedd:b7b2 dev dhcpcli proto ra metric 1024 expires 298sec hoplimit 64 pref medium
19
default via fe80::b0ec:c5ff:fedd:b7b2 dev dhcpcli proto ra metric 1024 expires 297sec hoplimit 64 pref medium
20
default via fe80::b0ec:c5ff:fedd:b7b2 dev dhcpcli proto ra metric 1024 expires 296sec hoplimit 64 pref medium
rm: cannot remove '/etc/dnsmasq.d/test.conf': No such file or directory
Connection 'dhcpcli' (0816d2d0-b070-4d9b-b630-5e4cc806ec48) successfully deleted.
=====

autoconf routes show up at second 3, and disappear second 8, then show up again
at second 17

Comment 2 Gris Ge 2019-07-30 16:15:47 UTC
Created attachment 1594701 [details]
System logs with NM trace enabled

Comment 3 Beniamino Galvani 2019-08-13 12:59:31 UTC
Probably those addresses are added by kernel because we leave 'accept_ra' set to 1, and so kernel does autoconfiguration even when it's disabled in NM.

Comment 6 Beniamino Galvani 2019-08-25 08:04:39 UTC
Created attachment 1607778 [details]
Script to check RA neigh parameters

The branch above disables kernel handling of RAs (accept_ra), that was introduced to fix bug 1068673. The parameters mentioned in the bug (retrans_time, reachable_time) are now handled by NM. This scripts can be used to verify that we still set the parameters correctly.

Comment 8 Edward Haas 2019-11-12 15:46:15 UTC
Requesting a backport to z-stream:

RHV is not expecting traffic disruption while updating a bridge interface.
The issue discussed in this BZ disrupts traffic and connectivity as it requires the usage if "activation" instead of "reapply".

It will be very helpful to have this issue fixed in 8.1.z so RHV can consume it from day 1.

Comment 14 errata-xmlrpc 2020-04-28 16:53:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847