Bug 1734564

Summary: Image Registry's service CA is constantly removed/re-created
Product: OpenShift Container Platform Reporter: Adam Kaplan <adam.kaplan>
Component: Image RegistryAssignee: Adam Kaplan <adam.kaplan>
Status: CLOSED ERRATA QA Contact: Wenjing Zheng <wzheng>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.1.0CC: aos-bugs
Target Milestone: ---   
Target Release: 4.2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: CVO, the image-registry-operator, and the service-ca injection controller simultaneously watched and updated the CA bundle used by the image registry. Consequence: The CA bundle used to establish trust between the internal registry and the rest of OpenShift was constantly removed re-created. Fix: CVO no longer manages the CA bundle. The image registry operator ensures the ConfigMap to hold the CA bundle is created, but does not manage its content. Result: The ConfigMap holding the CA bundle for the internal registry is only updated as needed by the service-ca injection controller.
Story Points: ---
Clone Of:
: 1739219 (view as bug list) Environment:
Last Closed: 2019-10-16 06:34:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1739219    

Description Adam Kaplan 2019-07-30 21:23:32 UTC
Description of problem:

The image registry operator creates a ConfigMap to inject the CA for the internal registry service. This CA is constantly wiped out by the CVO, only to be re-created by the ca-configmap-injector. 

How reproducible: Always


Steps to Reproduce:
1. Watch `oc get cm serviceca -n openshift-image-registry -o yaml`

Actual results:

Data is regularly removed/recreated (every 10 minutes or less), and revision number increases over time.


Expected results:

Data and revision number of the service CA is stable.

Comment 2 Wenjing Zheng 2019-08-14 08:31:16 UTC
Verified on 4.2.0-0.nightly-2019-08-12-153437, QE watches half an other, no overwritten.

Comment 3 errata-xmlrpc 2019-10-16 06:34:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922