Bug 1735795

Summary: [RFE] sosreport should capture /sys/kernel/kexec_crash_loaded for kdump validation
Product: Red Hat Enterprise Linux 8 Reporter: Rohit Keshri <rkeshri>
Component: sosAssignee: Pavel Moravec <pmoravec>
Status: CLOSED ERRATA QA Contact: Miroslav HradĂ­lek <mhradile>
Severity: high Docs Contact:
Priority: unspecified    
Version: 8.1CC: agk, bmr, mhradile, plambri, sbradley
Target Milestone: rcKeywords: FutureFeature, OtherQA
Target Release: 8.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: sos-3.8-1.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-28 17:01:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 1 Pavel Moravec 2019-08-01 13:24:21 UTC
As in bz1735794 :

My understanding is sosreport should collect:

/sys/kernel/kexec_crash_loaded
/sys/kernel/kexec_crash_size

Rohit, will you be able to test a package with the fix (once available)?

Comment 2 Rohit Keshri 2019-08-03 07:09:16 UTC
(In reply to Pavel Moravec from comment #1)
> As in bz1735794 :
> 
> My understanding is sosreport should collect:
> 
> /sys/kernel/kexec_crash_loaded
> /sys/kernel/kexec_crash_size
> 
> Rohit, will you be able to test a package with the fix (once available)?

yes sure.

Comment 5 Pavel Moravec 2020-03-03 14:10:31 UTC
(In reply to Rohit Keshri from comment #2)
> (In reply to Pavel Moravec from comment #1)
> > As in bz1735794 :
> > 
> > My understanding is sosreport should collect:
> > 
> > /sys/kernel/kexec_crash_loaded
> > /sys/kernel/kexec_crash_size
> > 
> > Rohit, will you be able to test a package with the fix (once available)?
> 
> yes sure.

Could you please verify the BZ against build http://download-ipv4.eng.brq.redhat.com/brewroot/////packages/sos/3.8/2.el8/noarch/sos-3.8-2.el8.noarch.rpm ?

I verified the codefix is in that sos version that is in RHEL8.2 errata - I just forgot to add this BZ to errata.

Comment 13 errata-xmlrpc 2020-04-28 17:01:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1900