Bug 1737102

Summary: vSphere UPI: invalid guest ID "other26xLinux64Guest" for clone. Please set it to "rhel7_64Guest"
Product: OpenShift Container Platform Reporter: Joseph Callen <jcallen>
Component: InstallerAssignee: Joseph Callen <jcallen>
Installer sub component: openshift-installer QA Contact: Gaoyun Pei <gpei>
Status: CLOSED ERRATA Docs Contact:
Severity: low    
Priority: unspecified CC: gpei, ocs-bugs, ratamir
Version: 4.2.0   
Target Milestone: ---   
Target Release: 4.2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1741287 (view as bug list) Environment:
Last Closed: 2019-10-16 06:34:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1741287    

Description Joseph Callen 2019-08-02 16:16:47 UTC
Description of problem:
Reported by Jan Safranek on #warroom-vmware
https://coreos.slack.com/archives/CH06KMDRV/p1564135021041400

* module.compute.vsphere_virtual_machine.vm[0]: invalid guest ID "other26xLinux64Guest" for clone. Please set it to "rhel7_64Guest"
* module.compute.vsphere_virtual_machine.vm[2]: invalid guest ID "other26xLinux64Guest" for clone. Please set it to "rhel7_64Guest"
* module.compute.vsphere_virtual_machine.vm[1]: invalid guest ID "other26xLinux64Guest" for clone. Please set it to "rhel7_64Guest"

The latest RHCOS OVAs have guest_id set to rhel7_64Guest rather than other26xLinux64Guest.

Comment 3 Gaoyun Pei 2019-08-24 04:12:11 UTC
PR#2145 works well with using rhcos-42.80.20190809.0, no such issue happened. Thanks.

Comment 4 errata-xmlrpc 2019-10-16 06:34:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922