Bug 1737175

Summary: Multi-arch support
Product: OpenShift Container Platform Reporter: Evan Cordell <ecordell>
Component: OLMAssignee: Evan Cordell <ecordell>
OLM sub component: OperatorHub QA Contact: Fan Jia <jfan>
Status: CLOSED ERRATA Docs Contact:
Severity: unspecified    
Priority: unspecified    
Version: 4.2.0   
Target Milestone: ---   
Target Release: 4.2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-16 06:34:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Evan Cordell 2019-08-03 11:51:10 UTC
Description of problem:

Hardcoded GOOS and GOARCH prevent multi-arch builds.

Comment 2 Fan Jia 2019-08-12 06:00:27 UTC
test env:
cv: 4.2.0-0.nightly-2019-08-10-002649
marketplace :quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:52a8be2309984fd5358e1d0b6fb28c64026cefc58a24ec23be7bdd61930f44eb

test result:
marketplace function is still ok after deleting the goos and goarch parameters.

Comment 3 errata-xmlrpc 2019-10-16 06:34:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922