Bug 1737206

Summary: python2: crash when importing PyQt5.QtCore
Product: [Fedora] Fedora Reporter: Orcan Ogetbil <oget.fedora>
Component: python-qt5Assignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: gavin, kde-sig, mads, projects.rg, public, rdieter, than, zbyszek
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-qt5-5.13.1-1.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-16 16:43:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1735995    

Description Orcan Ogetbil 2019-08-03 22:40:08 UTC
I came across this when trying to fix a FTBFS for libffado.
    BUILDSTDERR: Fatal Python error: PyQt5.QtCore: Unable to embed qt.conf
https://koji.fedoraproject.org/koji/taskinfo?taskID=36780372
Note that another fix (scons->scons-2) is needed in the rawhide package to get to this stage.

The bug seems to be reported to and fixed upstream. Apparently it only affects python2:
https://www.riverbankcomputing.com/pipermail/pyqt/2019-July/041896.html

Comment 1 Rex Dieter 2019-08-05 14:11:29 UTC
This should be fixed in the latest python-qt5 rawhide build,

%changelog
* Sun Aug 04 2019 Rex Dieter <rdieter@fedoraproject.org> - 5.13.0-1
- 5.13.0

Comment 2 Zbigniew Jędrzejewski-Szmek 2019-10-13 11:08:56 UTC
With the latest updates, this now happens in F30:

$ mock -r fedora-30-x86_64
<mock-chroot> sh-5.0# python2 -c 'import PyQt5.QtCore'
Fatal Python error: PyQt5.QtCore: Unable to embed qt.conf
Aborted (core dumped)

Affected version:
python2-qt5-5.12.3-6.fc30.x86_64

Comment 3 Kevin Kofler 2019-10-13 11:19:53 UTC
The problem is that 5.13.0 is intended for Qt 5.13, and F30 (and even F31 and Rawhide, at this time) only has Qt 5.12, so PyQt5 was reverted to 5.12.3. So this bug is back now.

Comment 4 Fedora Update System 2019-10-13 17:32:59 UTC
FEDORA-2019-723f2b467f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-723f2b467f

Comment 5 Fedora Update System 2019-10-14 17:04:42 UTC
python-qt5-5.13.1-1.fc30, sip-4.19.19-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-723f2b467f

Comment 6 gaxweb 2019-10-15 11:13:28 UTC
*** Bug 1761393 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2019-10-16 16:43:32 UTC
python-qt5-5.13.1-1.fc30, sip-4.19.19-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.