Bug 1737379

Summary: [4.1] drain takes 600s to evict the image-registry pod and container is still running afterwards
Product: OpenShift Container Platform Reporter: Antonio Murdaca <amurdaca>
Component: Image RegistryAssignee: Oleg Bulatov <obulatov>
Status: CLOSED ERRATA QA Contact: Wenjing Zheng <wzheng>
Severity: unspecified Docs Contact:
Priority: high    
Version: 4.1.0CC: aos-bugs, obulatov, wzheng
Target Milestone: ---   
Target Release: 4.1.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: the image registry was running from sh and signals were not propagated to the image registry. Consequence: the registry wasn't able to receive SIGTERM and it took few minutes to terminate the registry pod. Fix: replace sh with the registry process using exec Result: the registry is the pid 1 process and it's able to receive SIGTERM
Story Points: ---
Clone Of: 1729979 Environment:
Last Closed: 2019-08-28 19:54:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1729979    
Bug Blocks: 1729510, 1743846    

Comment 1 Antonio Murdaca 2019-08-05 09:07:18 UTC
Cloned the BZ because the MCO needs the fix for drain as well in 4.1, xref: https://bugzilla.redhat.com/show_bug.cgi?id=1729510
The PR linked in the MCO bugzilla is blocked on the image-registry backport (this BZ)

Comment 5 errata-xmlrpc 2019-08-28 19:54:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2547