Bug 1737622

Summary: tmpfiles.d/lirc.conf uses obsolete /var/run please update
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: lircAssignee: Alec Leamas <leamas.alec>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: bugzilla, hobbes1069, jarodwilson, leamas.alec
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-03 15:12:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Hans de Goede 2019-08-05 21:12:41 UTC
After running some dnf transactions the following warning is logged:

/usr/lib/tmpfiles.d/lirc.conf:1: Line references path below legacy directory /var/run/, updating /var/run/lirc → /run/lirc; please update the tmpfiles.d/ drop-in file accordingly.

Please update your tmpfiles.d config file(s) to use /run instead of /var/run.

Comment 1 Ben Cotton 2019-08-13 16:51:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Ben Cotton 2019-08-13 18:32:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 Richard Shaw 2019-12-10 13:10:03 UTC
No good solution here... It's defaulted to /var/run (which is already symlinked to /run) in lirc_options.conf.

If I change it but the user has modified lirc_options.conf then it won't pick up the changes. 

However, since it's symlinked it might "work anyway"... I'll have to do some testing.

Comment 4 Ben Cotton 2020-02-11 15:41:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 5 Alec Leamas 2020-11-03 15:12:21 UTC
hm... The relevant snippet in the specfile is

mkdir -p $RPM_BUILD_ROOT/%{_tmpfilesdir}
echo "d %{_rundir}/lirc  0755  lirc  lirc  -" \
    > $RPM_BUILD_ROOT%{_tmpfilesdir}/lirc.conf



i. e., this is really about how %{_rundir} is expanded. At least in F32 this is expanded to '/run', and lirc.conf is correct. Closing.