Bug 1738435

Summary: Fails to `fedpkg flatpak-build`, using excluded packages
Product: [Fedora] Fedora Modules Reporter: Milan Crha <mcrha>
Component: flatpak-runtimeAssignee: Owen Taylor <otaylor>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: klember, otaylor
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-13 10:35:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Milan Crha 2019-08-07 07:31:20 UTC
I'm not sure where to file this, thus let's start here.

I made evolution available for rpm2flatpak, just as [1] says.
I successfully 'fedpkg module-build' it [2], but 'fedpkg flatpak-build' fails [3].
If I read it properly, then it tries to mix liboauth/libcurl/libssh and fails due to excluded packages. I build liboauth as part of [2], thus I'd expect it'll work fine, but I do not know how this is supposed to work.

Any hints, please?

By the way, the [3] shows also other suspicious warning near the top, which is possibly related to the FileNotFoundError later in the log. I do not know how much expected it is.

[1] https://docs.fedoraproject.org/en-US/flatpak/tutorial/
[2] https://mbs.fedoraproject.org/module-build-service/2/module-builds/5297
[3] https://koji.fedoraproject.org/koji/taskinfo?taskID=36837603

Comment 1 Owen Taylor 2019-08-07 14:05:43 UTC
The problem here is that libssh grew a dependency on libssh-config with the Fedora 30 update to 0.9 and the Fedora runtime needs to be updated to match. (The container install is against the current Fedora repos, but the list of packages to include is based on the runtime.)

I'll look at updating and rebuilding the runtime.

Comment 2 Kalev Lember 2020-01-13 10:35:49 UTC
Closing as this was fixed a while back.