Bug 1740373

Summary: Cluster infrastructure CPU/memory accounting doesn't cover nodes, system level processes
Product: OpenShift Container Platform Reporter: Clayton Coleman <ccoleman>
Component: MonitoringAssignee: Clayton Coleman <ccoleman>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.1.zCC: alegrand, anpicker, erooth, ffranz, juzhao, lcosic, mloibl, pkrupa, surbania, wsun
Target Milestone: ---   
Target Release: 4.1.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1740372 Environment:
Last Closed: 2019-08-28 19:54:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1740372    
Bug Blocks:    

Description Clayton Coleman 2019-08-12 18:49:59 UTC
+++ This bug was initially created as a clone of Bug #1740372 +++

infrastructure CPU calculations don't take into account the processes running on the nodes.

Instead of the current calculation, find all workload CPU/memory usage not in the openshift-* namespaces, then subtract that from the cluster CPU usage to get infrastructure use.

--- Additional comment from Clayton Coleman on 2019-08-12 14:49:12 EDT ---

Metrics 

workload:cpu_usage_cores:sum
workload:memory_usage_bytes:sum

are added

openshift:cpu_usage_cores:sum
openshift:memory_usage_bytes:sum

now include all CPU/memory on nodes not explicitly part of a workload.

Comment 8 errata-xmlrpc 2019-08-28 19:54:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2547