Bug 1741065

Summary: [4.1.z]machine-config clusteroperator degraded reporting missing reason/detail information
Product: OpenShift Container Platform Reporter: Junqi Zhao <juzhao>
Component: Machine Config OperatorAssignee: Christian Glombek <cglombek>
Status: CLOSED ERRATA QA Contact: Micah Abbott <miabbott>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.1.zCC: amurdaca, cglombek, ecordell, jfan, kgarriso
Target Milestone: ---   
Target Release: 4.1.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1741062
: 1744764 (view as bug list) Environment:
Last Closed: 2019-09-20 12:29:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1744764    
Bug Blocks:    

Comment 1 Kirsten Garrison 2019-08-15 20:10:48 UTC
The way this PR is setup is stopping us from getting it proper labels in github.  I dont think these 4 other BZs should be linked to this one as "Depends On:" We are getting errors bc of this on github:

https://github.com/openshift/machine-config-operator/pull/1064

Specifically: https://github.com/openshift/machine-config-operator/pull/1064#issuecomment-521772815

Comment 2 Kirsten Garrison 2019-08-15 20:12:20 UTC
Antonio/Junqi can you remove the other BZ linked in the Depends On & Blocks sections of this BZ?

Comment 3 Junqi Zhao 2019-08-16 01:30:28 UTC
(In reply to Kirsten G. from comment #2)
> Antonio/Junqi can you remove the other BZ linked in the Depends On & Blocks
> sections of this BZ?

removed

Comment 4 Christian Glombek 2019-08-16 14:50:25 UTC
*** Bug 1741914 has been marked as a duplicate of this bug. ***

Comment 5 Kirsten Garrison 2019-08-23 22:19:58 UTC
The automatic cherrypick for this BZ didnt work =(

https://github.com/openshift/machine-config-operator/pull/1064#issuecomment-524277006

Comment 9 errata-xmlrpc 2019-09-20 12:29:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2768