Bug 174108

Summary: cciss fails to see device under xen0 kernel on HP Proliant DL380 G3 (non xen kernel is fine)
Product: [Fedora] Fedora Reporter: Tim Small <tim>
Component: xenAssignee: Rik van Riel <riel>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: katzj
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-11-24 12:15:38 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tim Small 2005-11-24 11:52:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
The HP CISS (formerly Compaq CCISS) driver fails to see any controllers, when loaded within the xen hypervisor kernel (also tried multiple FC4 xen/kernel-xen0 combos).

HP Proliant DL380 G3
1x 2.8GHz Pentium 4 Xeon
HP CCISS BIOS v2.58



Version-Release number of selected component (if applicable):
xen-3.0-0.20051109.fc5.3  kernel-xen-hypervisor-2.6.12-1.13_FC5

How reproducible:
Always

Steps to Reproduce:
Install xen, kernel-xen-hypervisor-2.6.12-1.13_FC5, reboot, wail, gnash teeth.  I also tried building the ciss driver into the kernel, with the same lack of results.

Actual Results:  Boot fails - inaccessible root partition

Additional info:

io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
Compaq SMART2 Driver (v 2.6.0)
HP CISS Driver (v 2.6.6)
Xen virtual console successfully installed as ttyS0
Event-channel device installed.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SvrWks CSB5: IDE controller at PCI slot 0000:00:0f.1
SvrWks CSB5: chipset revision 147
SvrWks CSB5: not 100% native mode: will probe irqs later
SvrWks CSB5: simplex device: DMA forced
    ide0: BM-DMA at 0x2000-0x2007, BIOS settings: hda:DMA, hdb:pio
SvrWks CSB5: simplex device: DMA forced
    ide1: BM-DMA at 0x2008-0x200f, BIOS settings: hdc:pio, hdd:pio
hda: DW-224E-A, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: ATAPI 24X DVD-ROM CD-R/RW drive, 1658kB Cache, UDMA(25)
Comment 1 Tim Small 2005-11-24 12:15:38 EST
Doh, my bad.  As part of the debugging that I was doing to 2.6.12-FC4-1456, I
tried disasbling IOAPIC mode on the xen command line.  This didn't fix the
problem, I then rebuilt the -devel FC5 kernel, and installed this, and the
kernel package carried the debug noapic setting over.  With this turned off, it
now works...

I will try and find out which kernel fixed it, and draft some changes for the
Fedora/Xen quickstart wiki.

Sorry for the bother...

Comment 2 Tim Small 2005-11-24 12:17:57 EST
To clarify, if I ommit the "noapic" xen boot time paramter, the
xen-3.0-0.20051109.fc5.3 + kernel-xen-hypervisor-2.6.12-1.13_FC5 combo now seems
to work...