Bug 1741208

Summary: unknown protocol 'gluster'
Product: [Fedora] Fedora Reporter: Jóhann B. Guðmundsson <johannbg>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: amit, berrange, cfergeau, dwmw2, itamar, pbonzini, rjones, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: qemu-3.1.1-2.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-22 01:17:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1684298    
Bug Blocks:    

Description Jóhann B. Guðmundsson 2019-08-14 13:49:43 UTC
Description of problem:

When creating a vm image on F30 virtualzation server with glusterfs storage pool it fails with virtio-disk0X: Unknown protocol 'gluster'

Normally one would just install "qemu-block-gluster" package but for whatever reason it's not being built for F30 o_O 

Version-Release number of selected component (if applicable):

qemu-3.1.1-1.fc30

How reproducible:

Always

Steps to Reproduce:
1. dnf install qemu-block-gluster
2. carefully inspect https://koji.fedoraproject.org/koji/buildinfo?buildID=1348234 for package
3.

Actual results:

No match for argument: qemu-block-gluster
Error: Unable to find a match: qemu-block-gluster

No packaged being built as visible observed in koji

Expected results:

qemu-block-gluster being built and available on 3.1.x release in F30 as it is for 3.0.x branch in F29 and 4.0.x branch in F31 

Additional info:

Comment 1 Richard W.M. Jones 2019-08-14 13:58:10 UTC
It was disabled a while back because of https://bugzilla.redhat.com/show_bug.cgi?id=1684298
and then reenabled.  However I can see that F30 was branched off from Rawhide while
it was disabled and it is still disabled in F30.  (This may not necessarily be wrong,
it depends if bug 1684298 was also fixed in F30).

Comment 2 Richard W.M. Jones 2019-08-14 14:04:50 UTC
There's a scratch build against F30 with the gluster block driver enabled here:
https://koji.fedoraproject.org/koji/taskinfo?taskID=37037336

Comment 3 Jóhann B. Guðmundsson 2019-08-14 14:07:48 UTC
I'll test it if it builds ;) 

Thanks for the quick response

Comment 4 Richard W.M. Jones 2019-08-14 18:23:28 UTC
Well it failed to build on ppc64le but that doesn't seem to have anything
to do with gluster (although the actual failure in migration does look
serious).  I have anyway pushed this change and submitted a real build:

https://koji.fedoraproject.org/koji/taskinfo?taskID=37040801

Probably this will fail so I won't be able to submit an update.

Comment 5 Fedora Update System 2019-08-15 07:31:27 UTC
FEDORA-2019-80e8403bf4 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-80e8403bf4

Comment 6 Fedora Update System 2019-08-16 19:50:41 UTC
qemu-3.1.1-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-80e8403bf4

Comment 7 Fedora Update System 2019-08-22 01:17:29 UTC
qemu-3.1.1-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.