Bug 1741265

Summary: Bare Metal Host power operation can be re-triggered
Product: OpenShift Container Platform Reporter: Jiri Tomasek <jtomasek>
Component: Console Metal3 PluginAssignee: Jiri Tomasek <jtomasek>
Status: CLOSED ERRATA QA Contact: Udi Kalifon <ukalifon>
Severity: high Docs Contact:
Priority: high    
Version: 4.2.0CC: aos-bugs, cvultur, ncredi, wzheng, xtian
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-23 11:05:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1744560, 1751978, 1817988    
Bug Blocks:    

Description Jiri Tomasek 2019-08-14 15:58:59 UTC
Description of problem:
Power on/off operation is triggered by setting host.spec.online boolean. UI should not wait for host.status.poweredOn to get updated to disable the appropriate power operation:

online: true, poweredOn: true -> host is powered on, can be powered off
online: false, poweredOn: true -> host is powering off, can be powered on
online false, poweredOn: false -> host is powered off, can be powered on
online true, poweredOn: false -> host is powering on, can be powered off

Comment 10 errata-xmlrpc 2020-01-23 11:05:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062