Bug 1741342

Summary: Do not call autoconf at build time
Product: [Fedora] Fedora Reporter: Marcos Mello <marcosfrm>
Component: squidAssignee: LuboŇ° Uhliarik <luhliari>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: anon.amish, code, jonathansteffan, luhliari
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-08 13:16:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marcos Mello 2019-08-14 20:21:40 UTC
0001-cppunit-config-no-longer-exists-use-pkg-config.patch is gone since

https://src.fedoraproject.org/rpms/squid/c/5dcaec0b66b9f0ab00ab2519da19b8e530bc7d4c

hence the autoconf call (%build section)

https://src.fedoraproject.org/rpms/squid/blob/master/f/squid.spec#_98

is no longer needed. "BuildRequires: autoconf" is not needed either.

Upstream fix:

https://github.com/squid-cache/squid/commit/459011abac01875851e1fe1e306fcf556b095bcb

Comment 1 LuboŇ° Uhliarik 2019-10-08 13:16:41 UTC
Thanks for your report! It has no sense anymore. Removing it, since we can use upstream
generated config script.

Commit: https://src.fedoraproject.org/rpms/squid/c/5caa9c3f2f1253f95bc2f71cb3bf7d2283e75947?branch=master