Bug 1744212

Summary: drop in replacement for bzip2?
Product: [Fedora] Fedora Reporter: Brian J. Murrell <brian>
Component: lbzip2Assignee: Mikolaj Izdebski <mizdebsk>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 30CC: lzap, mizdebsk
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-22 07:02:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Brian J. Murrell 2019-08-21 14:38:12 UTC
Description of problem:
Since lbzip2 performs sooooo much better on multi-core machines and given the prevalence of multi-core machines, it would be nice if lbzip2 could be installed *instead* of bzip2.  I.e. satisfy the RPM dependency for bzip2.

Comment 1 Mikolaj Izdebski 2019-08-22 07:02:28 UTC
Personally I agree, however this change proposal [1] was rejected [2] by engineering steering committee.

[1] https://fedoraproject.org/wiki/Changes/lbzip2
[2] https://pagure.io/fesco/issue/1276

Comment 2 Brian J. Murrell 2019-08-22 11:42:12 UTC
Is it time to re-propose the change?  5 years have passed since that last discussion.  lbzip2 is 5 year more mature.

Has a library interface been implemented?

Comment 3 Lukas Zapletal 2019-08-23 06:51:39 UTC
The original bzip2 was released 1996 I think, that's level of maturity lbzip2 can't achieve so the argument will be still quite relevant. However I would like to propose something different - can we implement "alternatives" for bzip2/lbzip2? I am not sure if this is the right term, but I mean /usr/sbin/alternatives for being able to switch between the two. Don't see this as a half-baked solution, it allows many people to try to switch and see if it works fine under various workloads. This change would probably require changes for both bzip2 and lbzip2 packages, I haven't implemented alternatives yet myself.

Comment 4 Brian J. Murrell 2019-08-23 14:55:20 UTC
Using alternatives was actually the original proposal that was shot down.

Comment 5 Lukas Zapletal 2019-08-29 07:40:53 UTC
Well, not really. It was proposed to "set higher priority for lbzip2 in alternatives" however what I think would be a good step forward would be only to provide alternatives and lbzip2 as opt-in.