Bug 1744344

Summary: RFE: moreutils for EPEL8
Product: [Fedora] Fedora EPEL Reporter: Japheth Cleaver <cleaver-redhat>
Component: moreutilsAssignee: Sven Lankes <sven>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: epel8CC: brandfbb, hatta, rfsmit, rybrown, siebrand, sven
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: moreutils-0.63-1.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-05 04:41:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Japheth Cleaver 2019-08-21 21:38:28 UTC
Description of problem:

Please create a branch for moreutils in EPEL8.

Note however that updates are needed in EPEL generally, as well as rawhide, as we're behind upstream by a bit.

See BZ#1168306 BZ#1551478

https://release-monitoring.org/project/13825/

Comment 1 Breno 2019-09-10 20:22:31 UTC
*** Bug 1746556 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2019-10-21 10:38:59 UTC
FEDORA-EPEL-2019-e2eaa397fa has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-e2eaa397fa

Comment 3 Fedora Update System 2019-10-21 16:38:52 UTC
moreutils-0.63-1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-e2eaa397fa

Comment 4 Fedora Update System 2019-11-05 04:41:32 UTC
moreutils-0.63-1.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 hatta@pezy.co.jp 2019-11-06 06:01:35 UTC
I tried to install on CentOS8 (centos:8 docker image) and got the following error.

[root@63c6800131dd /]# dnf -y install epel-release

...

Installed:
  epel-release-8-5.el8.noarch

Complete!
[root@63c6800131dd /]# dnf -y install moreutils
Failed to set locale, defaulting to C
Extra Packages for Enterprise Linux 8 - x86_64                                                                                                                                                                                                                                                                                                1.2 MB/s | 3.3 MB     00:02
Last metadata expiration check: 0:00:01 ago on Wed Nov  6 05:54:36 2019.
Error:
 Problem: conflicting requests
  - nothing provides perl(IPC::Run) needed by moreutils-0.63-1.el8.x86_64
  - nothing provides perl-IPC-Run needed by moreutils-0.63-1.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@63c6800131dd /]#

Comment 6 hatta@pezy.co.jp 2019-11-08 05:08:54 UTC
Sorry. PowerTools repo seems to be required.
'dnf -y --enablerepo=PowerTools install moreutils' works fine.

Comment 7 Rich 2020-01-25 00:09:49 UTC
Bear in mind please you're advocating subscribing to a new repo, for just one dependency, of just one "nice to have" package of a few kinda corner-case utils that very few people care or even know about. I'm prepping RHEL8 here for a closed environment, so that would require mirroring the entire repo, which would be hard to justify even for a critical package. No blame or anything, but please consider consequences of shuffling the deck before just saying "--enablerepo=PowerTools ... works fine". Thanks!