Bug 1746172

Summary: Unrelated volumes could be counted by volume counting predicates
Product: OpenShift Container Platform Reporter: Hemant Kumar <hekumar>
Component: StorageAssignee: Hemant Kumar <hekumar>
Status: CLOSED ERRATA QA Contact: Qin Ping <piqin>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.2.0CC: aos-bugs, aos-storage-staff, bbennett, fbertina, piqin
Target Milestone: ---Flags: piqin: needinfo? (hekumar)
Target Release: 4.2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-16 06:38:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Hemant Kumar 2019-08-27 20:24:13 UTC
Older predicates can incorrectly count volumes that are not bound yet (for delayed binding)

https://github.com/kubernetes/kubernetes/issues/80352

Comment 2 Hemant Kumar 2019-08-28 13:46:37 UTC
Fix openshift-  https://github.com/openshift/origin/pull/23682

Comment 9 Qin Ping 2019-09-06 04:36:48 UTC
verified with: 4.2.0-0.nightly-2019-09-05-234433

Comment 10 errata-xmlrpc 2019-10-16 06:38:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922