Bug 174661

Summary: LVM Volume Group Dialog not initialized with Physical Extent
Product: [Fedora] Fedora Reporter: Harald Hoyer <harald>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: thethirddoorontheleft
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-05 19:45:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150222    

Description Harald Hoyer 2005-12-01 07:22:09 UTC
If you have an existing LVM volume group > 262144MB, you cannot "Edit" a logical
volume and assign a mount point, because a dialog is popping up, saying that you
have to increase your "Physical Extent" for this Volume Group.
This can be fixed by initializing the physical extent combobox, which cannot be
selected for existing volume groups.

Comment 1 Darwin H. Webb 2006-01-01 23:54:41 UTC
The install of Jan 1, 2006 was on existing Vol groups and LogVol's.
Went the mount point and format needed to be specified for the LV,
if the LV was the last in the VG and there had been free extents (in my case 1
free extent at the end of the VG - which I planed as I understand that at least
1 free extent is needed to extent the VG to another?),
then the GUI tool said the there was -1x<extent-size) i.g. -32MB,
vs. +1x<extentsize.
The LV had to be deleted and recreated. The new create showed max size as
1x,extentsize> smaller (not 2).

Needs some math done in the GUI?

SJ

Comment 2 Darwin H. Webb 2006-01-02 20:36:07 UTC
The LV name is too short, only allows about 16-20 characters.
needs at least 30-32

Creating partiton to use as PV - mount point is N/A but there is no indication
that it will change to N/A and is very confusing.
Please add a few more descriptive words for the seq of creating PV, VG, LVs


Extent size defaults to 4 MB and could not be changed. This will not work on
volumes over 255 GB which would need larger extent sizes.

Default LVM install configuration does not indicate what it is going to create.

Darwin

Comment 3 David Cantrell 2006-02-03 20:06:49 UTC
Harald:
-------
The physical extent size cannot be changed after the volume group is created. 
You can create more physical volumes and add them to the group, which increases
the number of physical extents you can use, but you cannot change the size. 
That's why the combo box remains greyed out.  I changed the text in the dialog
box to offer a better explanation.  This is now in rawhide.


Darwin:
-------
The logical volume name limit has been increased to 32 characters.  The physical
extent size now defauls to 32MB.  These changes are in rawhide.

The problem described in comment #1 about the numbers in the GUI displaying
incorrect values.... I need some more information to go on because I can't
recreate what you're describing.

Comment 4 Harald Hoyer 2006-02-06 08:52:38 UTC
David, it is ok, that the combobox is greyed out. But please initialize it to
the right value... MY PHYSICAL EXTENT SIZE IS ALREADY BIG ENOUGH :)

If you have an existing LVM volume group > 262144MB, you cannot "Edit" a logical
volume and assign a mount point, because a dialog is popping up, saying that you
have to increase your "Physical Extent" for this Volume Group, THOUGH IT IS
ALREADY INCREASED.
This can be fixed by initializing the physical extent combobox, which cannot be
selected for existing volume groups.



Comment 5 David Cantrell 2006-02-09 21:00:15 UTC
In my test installs with rawhide, the physical extend value is initialized to
whatever the existing LVM volume group has.  I'm able to set mount points
correctly.  Have you tried this with rawhide?

Comment 6 Darwin H. Webb 2006-02-09 22:19:57 UTC
The extent problem I encountered was not about the size of the extent nor the
size of the VG. (Although having a dropdown for extent size and block size on
the ext3 would increase the performance of my computer disk by a 3x. I am sure
of that as a 1024 block size it getting 7-9 MB/s and with a 4K block it would be
18-22 MB/s. It is not so noticably on a 100 ata or 150 sata but on my 33 udma it
is very apparent. And I don't mind the extra 200 MB out of a 32 GB partiton.)

It was telling me that my exsisting LV could not be mounted because the exsiting
LV was bigger (according to the space size field) by one extent -32MB and that
the LV had to be reduced to fit in the space on the VG. When in fact the LV was
smaller then the VG space and there was 1 extent left on the VG +32MB - which I
did on purpose for extenting the VG)

After deleting the LV and creating another for that space it then said it was
exactully equal to the space, although the size of the LV had only change by
32MB and there was now zero extents left on the VG.

This was probably due to the orginal being created by a difference rev of LVM2
and / or a different distro. 

It will probably only cause a problem for those re-installing onto existing LV's
and I think it is only occuring on the last LV of a VG.

I can not reproduce it from here as all my LVM's are current and the distros
that use LVM are current. (But someone somewhere may get caught and have to
delete the /home or /hoursofvideo LV from another install before it can be mounted?

Darwin

Comment 7 Darwin H. Webb 2006-03-13 01:28:33 UTC
There is something going on in this area again.

I have a Pent III and a Pent IV with FC5 http installs and all the upodates.
On the Pent III I installed Ubuntu 6.04 dapper drake on the hda using the Ubuntu
installer. I created an pv/vg on hda3 and 3 lv's of root, home and swap.
It used all of the vg space (no 32 mb extent at the end.

Today I installed the 2045 kernel on the PENT III and latter opened the LVM GUI
tool and it would not start. I tried a second time and it would not start.
I looked as the vg's and lv's and saw the Ubuntu vg had no free extent at the end.

I went to the Pent IV and opened the lvm gui tool and it was ok (showed FC5 vg,
lv's with 1 free extent at the end of the vg.

The only difference was the 2045 kernel.
I instaleed the 2045 kernel and rebooted.
Opened the lvm gui tool and it opend ok, vg has one free extent of 32MB.

I wnet to the Pent III and used the cli lvm interactive command to reduce the
last lv by one extent (it was a swap so it did not have data on it)
I opened the lvm gui tool and it would not open.

Darwin



Comment 9 Darwin H. Webb 2007-01-25 21:49:45 UTC
This bug can be closed.
LVM2 has been updated several times.
Older distro's may still be a problem but
I can't reproduce this now and, hopefully, that condition will not last for long.

Darwin 

Comment 10 David Cantrell 2007-03-05 19:45:15 UTC
Closing based on comment #9.