Bug 174732

Summary: firefox 1.5 isn't visible via AT-SPI
Product: [Fedora] Fedora Reporter: Zack Cerza <zcerza>
Component: firefoxAssignee: Christopher Aillon <caillon>
Status: CLOSED CANTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: marius.andreiana, mcepl, mcepl, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: FF3RawhideClose
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-12-20 16:48:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 169147    

Description Zack Cerza 2005-12-01 19:23:45 UTC
Description of problem:
When Firefox 1.5 is launched with accessibility enabled, it isn't visible via
the accessibility framework.

Version-Release number of selected component (if applicable):
firefox-1.5-1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start Firefox
2. Start at-poke
3. Look for Firefox
  
Actual results:
You don't find Firefox

Expected results:
You find Firefox

Additional info:

Comment 1 Zack Cerza 2005-12-01 19:26:10 UTC
It works, *sorta*, if you start it like so:

$ GTK_MODULES=gail:atk-bridge firefox

but I only see 3 nodes, which is still wrong.

Comment 2 Matěj Cepl 2007-12-20 16:48:05 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays