Bug 1747647

Summary: player fails to build with Python 3.8 on Fedora 32+
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: playerAssignee: Rich Mattes <richmattes>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: kwizart, richmattes, robotics, TicoTimo, tim
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-22 18:53:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1686977, 1750908, 1750909    

Description Miro Hrončok 2019-08-31 12:57:38 UTC
player fails to build with Python 3.8.0b3 in Fedora 32.

See the build failures at https://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=player

It is a dependency problem:

No matching package to install: 'festival-devel'
No matching package to install: 'gstreamer-devel'

It is not important the problem is not relevant to Python 3.8, this issue is blocking the Python 3.8 rebuilds.
If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32 and further.

Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Please rebuild the package in Fedora 32 (rawhide).

Let us know here if you have any questions. Thank You!

Comment 1 Rich Mattes 2019-09-04 23:33:05 UTC
Looks like both of those packages are retired in f32.  They're both optional deps, so I removed the BuildRequires on them both and will rebuild once the current build finishes failing.

Comment 2 Miro Hrončok 2019-09-04 23:49:01 UTC
I've cancelled the current build.

Comment 3 Rich Mattes 2019-09-05 00:28:43 UTC
Thanks!  I rebuilt, and now it looks like it's failing due to a problem with proj in the OpenCV dep chain.  OpenCV depends on VTK, and VTK depends on proj.  proj just had a soname bump - there's a thread on fedora-devel about it.  I'll follow that and rebuild once the required packages are ready.