Bug 174765

Summary: regression in ssh-add window formatting
Product: [Fedora] Fedora Reporter: Alexandre Oliva <oliva>
Component: opensshAssignee: Tomas Mraz <tmraz>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: mefoster
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: openssh-4.2p1-10 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-12-20 10:19:42 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Alexandre Oliva 2005-12-01 18:16:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
When you run say `ssh-add < /dev/null' with DISPLAY set (the idea is that it opens a window to prompt for the key passphrase, instead of using the terminal), the spot in which you enter your password on the left is very small compared with what appears to be a randomized progress bar that moves around as you enter the passphrase.

I understand this is probably intentional, as a means to not provide information about the passphrase length to anyone who might be looking at the screen, but it does look very confusing.  After first it gave me the impression of a layout bug.  In fact, I'm not entirely convinced this is not the case :-)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run ssh-add < /dev/null

Actual Results:  Odd window shows up, user confused, not sure where to enter the passphrase :-)

Expected Results:  Something that looks less confusing, or some text explaining the idea behind hiding the passphrase length

Additional info:
Comment 1 Tomas Mraz 2005-12-02 04:22:20 EST
It is of course intentional and I don't think that even if it is confusing it
makes much harm because you can simply try to enter the passphrase to the entry
which is btw focused by default.

If you have a better idea how to make it so passphrase length is not revealed
please share it. I will add 'Passphrase length hidden intentionally' text to the
progress bar for now.
Comment 2 Mary Ellen Foster 2005-12-09 18:12:20 EST
I found it *extremely* confusing; I don't think I've ever seen a dialog box
where I'm supposed to enter a multi-character value into a one-character-wide box.

You could maybe create a normal-sized entry field for the passphrase, and just
not echo anything when the user types into it? That might be confusing too, but
less than the current set-up. I spent a non-trivial amount of time trying to
type my passphrase into the scrollbar. :)
Comment 3 Tomas Mraz 2005-12-20 10:19:42 EST
Hopefully the situation is now improved with the added text.
Comment 4 Alexandre Oliva 2005-12-21 10:19:22 EST
Looks much better, indeed.  Thanks!